Super key (Windows meta) not working to open application launcher

Hi folks, I’ve been searching throughout all forums known to humankind trying to solve this, but I couldn’t figure out how. I noticed that everything works fine in another user, but not the one I work on.

Would any of you has any idea about where I can start to debugging this? Thanks in advance!



Have you tried this fix?


Hm, that’s funny. I did try this one before and nothing happened, but I updated the system just now and worked!


Oh boy, here we go again… The launcher stopped working and this solution doesn’t work anymore :confused: .

Found (kinda?) a solution to your problem. If you type krunner in the terminal, you’ll get the same run launcher you get in the applications menu on the top of your screen. I couldn’t find the binary for the actual application launcher which is the Manjaro icon on your taskbar, so I hope this suffices. It’s basically the same thing without the GUI menu, and you can search for applications, files etc.

You can now map this to a custom keyboard shortcut, and you can do this by going to System Settings -> Shortcuts -> Custom Shortcuts -> Edit -> New -> Global Shortcut -> Command/URL. Name the shortcut whatever you want. In the trigger section of the shortcut, click where it says “None” (which means there is no trigger currently assigned to the shortcut) and press the super key. It will ask you to overwrite the shortcut because the super key is already used by the application launcher. Now go to the Action section of the shortcut and type krunner and save the changes. Now whenever you press the super key you’ll get krunner. Hope this helps.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.