Super Key problem with QEMU/KVM Gnome Virtual Machines using Manjaro Gnome Host

After the updates of Sep 18:

When using QEMU/KVM Manjaro Gnome host, any Guest VM using the Gnome Desktop has this problem:

When using the guest OS, a single press of Super Key should open the Activities Overview of the guest OS. Instead, it opens the Activities Overview of the Host.

This behavior is seen on two Manjaro computers here hosting VMs with Gnome desktop.

I have been using one of these VMs regulary in my work. This problem is sufficiently inconvenient that I moved the VM to a Fedora Workstation host under which the Super key works as it should.

Is there a fix to restore the Super Key’s correct function in the Guest OS?

A solution is not so simple as just re-defining a keyboard shortcut “Super” for the action “Show the Overview” defined in under:

Keyboard Shortcuts > System

This can’t be done for Super key used alone. Super Key can only be user defined in conjunction with another key, like Super+L.

I appears that the single key press of Super Key is part of Gnome and not user definable within the shortcut dialogs.

Finally, there is already a two key shortcut (Super + S) defined for “Show the Overview”. It gives the same incorrect action as Super alone.

There were so many packages in the Sep 18 updates that it is impossible for me to identify any package that might have introduced this problem in order to report it.

Still need a fix.


I use the same setup (virtual machine manager + QEMU/KVM) and do not experience this behavior.
This thread on the arch forum might be relevant: Virt-Manager + Super key / Applications & Desktop Environments / Arch Linux Forums

I’m not able to reproduce the behavior, I run wayland on host and guest, this might have something to do with it.

Thanks for the reply.
I looked into your suggestion about both host and guest using Wayland. My host Manjaro can only use the Wayland session now (another problem resulting from the Sep 18th updates). The guest shows the super key issue with both Xorg or Wayland sessions.

I will look over the Arch Linux link you provided next.

A more succinct restatement of the problem:

Using a gnome guest VM in fullscreen mode with Manjaro Gnome host:

Any keyboard shortcut using Super key tried on the guest OS is being sent to the host, not the guest.

Super + PgUp switches workspace on the host, not the guest.
Super + A shows applications grid on the host, not the guest.
Super + S shows overview screen on the host, not the guest.
Super (alone) shows overview screen on the host, not the guest.

That’s the situation in a nutshell.

Notes: workspace switcher on the guest panel works correctly; activities button on the guest panel works correctly.