<Super> + I key combo broken

Hi I’m new to Manjaro. Recently I came accross an issue where I can’t seem to be able to use the short cut <Super> + I in VSCode(or any other app for that matter). I have my arrows mapped to this combo but now it appears to be broken. When testing with other apps usually there’s no shortcut assigned but the letters L,K,J when pressed with Super do show up in the text field but whenever I press ‘I’ in combination with Super it doesn’t work at all. The key combo works in the default keyboard shortcuts window in settings but doesn’t seem to work in any other app.
Individually those keys work just fine.
This problem also persist on my right super key aswell.
Any insights or help is appreciated.

Edit :
My other combo Super + Shift + I works just fine.
I tried gsettings list-recursively aswell to find if the shortcut is bound to anything, but it’s not bound to anything what’s so ever.

I think that shortcut is reserved by the shell. Btw, does vs code usually use super+I for something? Super key is usually reserved for desktop, not apps.

I’m not sure about the shell part you mentioned but I use that shortcut daily in my workflow, it used to work on my previous installation of manjaro. It seems to be broken in this one. I actually use that shortcut as my up arrow alternative, while J K L act like the rest of the arrow keys.

Superl is - as @Chrysostomus points to - usually handled by the shell - what ever shell it is - and it is common - very common - that this combination is used for the lock screen action.

I know this because I am/was used to use the combo to format my source code in Jetbrains tools and I have remapped or used to remap the key combo for formatting not to accidentally collide with screen locker.

Can you image how many times I have locked my screen :laughing: on that behalf - because I can’t count them.

when I press the Super + A I get the applications menu, here the Super + I combo atleast prints the I key unlike previously where apps won’t even recognize it.
This leads me to believe something within Gnome is trying to capture that input and not do anything with it.
It even works in the ArcMenu, anywhere but the apps that I need it to work on.
Edit 2 :
When I switch to GNOME classic during login the shortcut works like I intend it it to.
However, I tried it on GNOME regular (Wayland) and GNOME XOrg it doesn’t work.
So I would like some help me to figure out how different is Classic from regular gnome so as to drill down to what’s causing the issue