Sudo ufw enable ”to make ufw auto start “On” (after a reboot), is not working

/etc/ufw/ufw.conf ENABLED=yes
But after a reboot

#ufw status

Throws

Status: inactive

Could iptables.service be conflicting with UFW?

Do i need to do this?

sudo systemctl stop iptables.service
sudo systemctl disable iptables.service
sudo systemctl enable ufw

reboot

that’s all to do

2 Likes

Can you use google for once or do you have to ask every single thing every day?

1 Like

Some of the data i found on google mentioned #sudo enable ufw - only.
I will research on “systemctl”, but it seems this command is needed for a lot of functions in manjaro.

I’ll start going over as much info i find in google before i ask questions.
I’m realizing a lot of things are reversible in linux, anyway.

yes it is
https://wiki.archlinux.org/title/Systemd

If you type ‘manjaro enable ufw’ into google, literally first result is this: Firewalls - Manjaro

I’m just gonna start flagging topics like this. :smiley:

1 Like

You’re right.

But notice how it mentions only sudo ufw enable
The service was (i believe) already enabled.

If service was enabled, then it would start after reboot.

I don’t know why it’s started directly in wiki instead of with systemctl, but it doesn’t matter.

… you mean:
how your screenshot from who knows what source mentions it?
right

it’s just not how it works - and wherever you got it from they got it wrong

stick to the Arch wiki, it’s excellent - or Manjaro wikis

It’s from manjaro wiki. :smiley:

it is?
does it actually work - or is it even supposed to?

I have never seen the Arch wiki being wrong - not so sure about the quality of Manjaro Wiki posts though.

yes i’ll start giving more info not to leave anyone blind.
As @zbe pointed , it’s from manjaro’s wiki.
I’ve realized manjaro and arch’s wiki are the 1st point of info on manjaro configuration and app setup.

It does work now! But only after i issued: # sudo systemctl enable ufw

It needed “systemctl”.
For someone quite junior in linux and new to manjaro, some things are specific.

I have never seen the Arch wiki being wrong - not so sure about the quality of Manjaro Wiki posts though.

Glad you mention this and not pointing anything on manjaro wiki.
But arch’s info is really well documented!

It enables service, but then starts ufw directly. So yes it works, but it doesn’t make sense to me. But on the next reboot service will start it anyway.

Someone should just edit wiki and replace both lines with

systemctl enable --now ufw.service
1 Like