Sudo suddenly stopped working!


-I just rebooted my Notebook with a current Manjaro on and since then I cannot use sudo anymore.
but I always get “Das hat nicht funktioniert, bitte nochmal probieren.”
Of course I know the password, there’s no Capslock or other stuff, and I even tried resetting the password, to no avail.

I checked the few requirements of which I knew and found:
-sudo group disappeared
-sudo group is commented out in sudoers file

I recreated the sudo group, added my user to the group and enabled sudo group in sudoers file

I tried checking the log file, but the path names I found online don’t seem to apply. I could not find a sudo log
I removed and reinstalled sudo from ‘software’

But nothing of this helped.

Please help :frowning:

On manjaro and some other distro the default group that has sudo access is not sudo but wheel


So there normally is no sudo group at all?

I just checked ‘wheel’. My user is in there.

Have you been copying .pacnew files over existing files?

You may be able to salvage your system if you have working copies of /etc/group and /etc/passwd

Verify the following files exist and has the desired content - please note the appended dash in the filename - it is a backup created by the system - created every time you change the files

  • /etc/group-
  • /etc/passwd-

If those files has the expected content - especially verify if your username is found in the line of the wheel group - then simply copy those files to their original names - which is without the dash (’-’).

$ cat /etc/group- | grep wheel 

This will require root - so use su to change to root and do the copy.


But - please do make sure what you are doing - and if at all in doubt - make backups first like this

# cp /etc/group /etc/group.backup.20200922
# cp /etc/passwd /etc/passwd.backup.20200922
1 Like

Just checked sudoers file for the ‘wheel’ group.
‘wheel’ was commented out for no reason, I uncommented the 'wheel line, but it still doesn’t work.

I did not do anything with the packet manager or authentication files. I was busy configure a printer in cups when I rebooted.
I just made backups of all 4 files and replaced the standard group and passwd with their ‘-’ copies. Now rebooting.

What is in sudoers doesn’t matter much.

# cat /etc/sudoers.d/10-installer

Which enables the wheel group.

Now why it is named 10-installer - that I don’t know - but it is there and doing its job.

1 Like

Thank you! It’s working again! :smile:

(And probably it worked without rebooting, because I realized that otherwise “sudo reboot” wouldn’t have worked :sweat_smile:)

Can you tell me what went wrong there? Is it just a matter of quantum fluctuation, where maybe ECC-RAM would have helped? Or is there any bugged software that corrupted the password/group file (without a reason, because I didn’t make any changes there, so no process should be writing to these files…)

1 Like

I haven’t got the foggiest.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.