Sudo, Pacman not working in Manjaro

I just upgraded the base-devel package in Manjaro. Now after rebooting it showed me error

Failed to start Authorization Manager.

I changed my grub configuration and login to my account using terminal.

But whenever I run the command to update or upgrade anything to fix it. It again throws an error.
e.g. pacman -Syu
pacman: /usr/lib/ version ‘GLIBC_2.33’ not found (required by pacman)
pacman: /usr/lib/ version ‘GLIBC_2.33’ not found (required by /usr/lib/

As you can see in this case, neither sudo neither Pacman is working as both are dependent on this GLIBC_2.33. To fix or update this package I again need Pacman to work.

Please help me out!

It sounds as if you did a partial upgrade which is not supported.

Edit: Removed reboot note, sorry.

So, What Can I do Now ?

Use a live USB, chroot into your installation and run pacman -Syyuu

I am a fresh user of Manjaro. I don’t know exactly how to do this. Can you please explain me how to do this ?
All I know is my root partition is installed on my sda9 partition


to fix this :

  • you need bootable manjaro usb
  • boot from usb
  • mount manjaro partitions
  • use this command :
    pacstrap -i /mnt glibc lib32-glibc

Yeah I mounted the partition and now after running command you mentioned. It is showing me

command not found : pacstrap

before use pacstrap use this command
sudo pacman -S arch-install-scripts

In the chroot window of live usb it is still showing me
GLIBC_2.33 not found error

do not need chroot.
in manjaro live mount your system partitions and now enter this commands :
sudo pacman -S arch-install-scripts
pacstrap -i /mnt glibc lib32-glibc


How should he do that when pacman is broken
Edit ok, i see, without chroot


or you could: chroot into your system, then use the static version here:

chmod +x pacman-static
./pacman-static -Syyu glibc lib32-glibc

Thank you very much you saved me! You are a blessing for me.
Thanks pacstrap method worked for me.

Pacman not broken in live manjaro
he most install arch-install-scripts with pacman in live manjaro after use pacstrap to install glibc and lib32-glibc.
or he can use your commands

Yes I used Pacman of my live usb to fix Pacman of my Manjaro installation.

brefore using manjaro i using arch.
and i have this proplem in arch.
and i fixed this with live arch.

1 Like

Got it. Didn’t read properly. :wink:

Any suggestions so I can avoid this in future ?

DO NOT ! remove any pkg which you do not know
and sorry if i not able to type English correctly.
i am 12 ! years old and my language not en.
i am Iran and my language is Persian.

Nice, well done kid. I am also 17 yrs old from India :kissing_heart:

for example i remove all pkg with k is first letters in arch and after “I CAN NOT USE SUDO AND PACMAN AND MY SYSTEM NOT BOOT”
I fixed this with live arch.