Suddenly WiFi will not connect after sleep or hibernate


Started looking into this in another group (Kernels) but seems more appropriate here.

After the latest large update I have lost the ability to wake after sleep and/or hibernate and have access to wifi.

The system cycles through trying multiple times and just will not connect. Strange thing is even though it’s telling me “wireless network could not be found” after three or four tries suddenly all the networks in the area are listed (so the card is activated?) but it just will not connect and allow me to use it.

I was getting connected eventually “sometimes” either letting the system do it’s thing or restarting multiple times, but now I’m just stuck with no wireless.

I tried to go to the next kernel that came out 5.11.1-1 and that has no effect (saw something about Broadcom go by while updating and was hopeful).

I’m on a wired connection at the moment.

Wifi card is: Broadcom Inc. and subsidiaries BCM4313 802.11bgn Wireless Network Adapter (rev 01)

I am running Manjaro Nibia 20.2.1 with Kde desktop.

On a Dell 5420 laptop with Intel i5-2520m with 8gb ram.

Pretty new to the whole Linux system so if any further info is needed please include the command(s) to get that.

Any help/advise as to where or what else to look for/at is greatly appreciated as this is getting Very frustrating.

Thanks in advance!

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)


Sorry for the delay, very busy.

Still doing it every time it comes out of sleep or hibernation. I have tried both with the same results.

Sort of just putting up with it due to the limited time I have had lately.

It will recognize the wifi card “eventually”, time can be from maybe a couple of mins. too 10 mins. Then it will suddenly become “activated”. Strange thing is even as it will not connect it is using the card because I can see everything in the area listed including someones fridge…

If something else is needed just let me know.

the output to inxi --admin --verbosity=7 --filter --no-host --width is:

  Kernel: 5.11.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-x86_64 
  root=UUID=78030098-10f0-4706-8f93-fec76040459a rw quiet apparmor=1 
  security=apparmor resume=UUID=fb98904c-3aad-46d0-9d90-c6300a25ba46 
  Desktop: KDE Plasma 5.21.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux 
  Type: Laptop System: Dell product: Latitude E5420 v: 01 serial: <filter> 
  Chassis: type: 9 serial: <filter> 
  Mobo: Dell model: 0H5TG2 v: A02 serial: <filter> BIOS: Dell v: A14 
  date: 12/26/2013 
  ID-1: BAT0 charge: 73.8 Wh condition: 73.8/73.3 Wh (101%) volts: 12.5/11.1 
  model: Samsung SDI DELL 5CGM4A7 type: Li-ion serial: <filter> status: Full 
  Device-1: hidpp_battery_0 model: Logitech M570 serial: <filter> charge: 25% 
  rechargeable: yes status: Discharging 
  RAM: total: 7.67 GiB used: 2.47 GiB (32.3%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i5-2520M bits: 64 type: MT MCP 
  arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F 
  L2 cache: 3 MiB bogomips: 19963 
  Speed: 798 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 798 2: 798 3: 978 
  4: 798 
  Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov 
  constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept est 
  flexpriority flush_l1d fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce md_clear 
  mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm 
  pebs pge pln pni popcnt pse pse36 pti pts rdtscp rep_good sep smx ssbd sse 
  sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0126 
  class ID: 0300 
  Device-2: Sunplus Innovation Laptop_Integrated_Webcam_FHD type: USB 
  driver: uvcvideo bus ID: 1-1.4:3 chip ID: 1bcf:280b class ID: 0e02 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: intel unloaded: modesetting alternate: fbdev,vesa display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4") 
  s-diag: 485mm (19.1") 
  Monitor-1: LVDS1 res: 1600x900 hz: 60 dpi: 131 size: 310x170mm (12.2x6.7") 
  diag: 354mm (13.9") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) 
  v: 3.3 Mesa 20.3.4 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1c20 class ID: 0403 
  Sound Server: ALSA v: k5.11.2-1-MANJARO 
  Device-1: Broadcom BCM4313 802.11bgn Wireless Network Adapter 
  vendor: Dell Inspiron M5010 / XPS 8300 driver: wl v: kernel modules: bcma 
  port: 7040 bus ID: 02:00.0 chip ID: 14e4:4727 class ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Broadcom NetXtreme BCM5761 Gigabit Ethernet PCIe vendor: Dell 
  driver: tg3 v: kernel port: 7040 bus ID: 0a:00.0 chip ID: 14e4:1681 
  class ID: 0200 
  IF: enp10s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Message: No Bluetooth data was found. 
  Message: No RAID data was found. 
  Local Storage: total: 232.89 GiB used: 66.17 GiB (28.4%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Smart Modular Tech. 
  model: SHGS31-250GS-2 size: 232.89 GiB block size: physical: 4096 B 
  logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 0Q00 
  scheme: MBR 
  Optical-1: /dev/sr0 vendor: PLDS model: DVD+-RW DS-8A8SH rev: KD11 
  dev-links: cdrom 
  Features: speed: 24 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw size: 224.08 GiB size: 219.57 GiB (97.98%) 
  used: 66.16 GiB (30.1%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 78030098-10f0-4706-8f93-fec76040459a 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.8 GiB used: 5.8 MiB (0.1%) priority: -2 
  dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: fb98904c-3aad-46d0-9d90-c6300a25ba46 
  Message: No Unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip ID: 8087:0024 class ID: 0900 
  Device-1: 1-1.4:3 info: Sunplus Innovation Laptop_Integrated_Webcam_FHD 
  type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1bcf:280b class ID: 0e02 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip ID: 8087:0024 class ID: 0900 
  Device-1: 2-1.4:3 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID 
  driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  chip ID: 046d:c52b class ID: 0300 
  System Temperatures: cpu: 58.0 C mobo: 43.0 C sodimm: SODIMM C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 187 Uptime: 4h 47m wakeups: 20 Init: systemd v: 247 Compilers: 
  gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1439 lib: 435 flatpak: 0 
  Shell: Bash v: 5.1.0 running in: konsole inxi: 3.3.01
  1. In the future, when providing code/output, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text so that the output looks like this:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
    Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
    Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur.
    Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

    instead of like this:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

    (as that makes both our lives much easier)

  2. No need to do anything right now as I’m an editor here on this site and have fixed it for you already. However, in the future I might not see your post so review my edits by pushing the orange pencil above the post I just fixed. :wink:

  3. Have you tried kernel 5.4 LTS (Long Time support) or 5.10 LTS already in that order?


1 Like

5.10.19-1 started the problems, I don’t have that with the LTS designation.
5.4.101-1 LTS is available, I will try that and see what happens.

Problem seems to have gotten worse, the last two times trying to activate after the night off or a long time during the day (hibernate) it is taking 20+ mins. and a ton of retries to get it to recognize the card.

Any ideas why it can see everything around (tv’s/fridge/printer and a half dozen other networks) which to me would mean it was “seeing” the card but just will not “activate” it and connect up to the network?

Sorry about the formatting! I will try booting into 5.4 LTS and see what happens.




5.4 LTS sometimes works upon wake, sometimes not. Just now I waited until the system tried to establish the connection and failed 4 times then it just sits there. I go to networks and sure enough all surrounding networks are seen, click on reset and it comes up.

The only new thing I noticed with 5.4 is that in the notifications popups I’m getting I am only seeing "Wireless Interface (wlp2so) The WiFi network could not be found " but not the notices about not seeing the card itself. There used to be two separate messages (notices) every time it tried to connect. Sorry I don’t remember the wording exactly, if it happens again I will copy it down.

I will try 5.10 again shortly and see what happens with that.

Thanks to anyone reading!

Hello, I never use hibernating, I just tried today - and it failed.

Concerning the WiFi issues, looks like the one I also get there, along with a fellow KDE user Plasma-nm package doesn't connect at first attempt

1 Like

Thanks! That’s the same message(s) I get over and over until it decides to connect or stops trying and I have to go and “connect” manually. Just different language of course.

Had a few mins. to jump on and just went through it again for 10+ mins. trying over and over until it hooked up. The strangest thing as I have said is it’s apparently not the card itself because ALL networks in the area are listed, even someones fridge of all things. Never saw that one before.

Hibernation is just handy for a laptop if I leave it in another room knowing I will be back to save the battery. I have adjusted the power settings for being plugged in open or closed but wouldn’t mind it there as well so fans and such don’t have to run.

Thanks for reading and/or the response!

Hi, no problem, it’s nice (so to speak) to see other people with the same issue. The more we are, the fastest we’ll find a solution.

I’ll link this post into the other, so that we’ll be all aware in case an idea comes up.

Concerning hibernation, I don’t know if it’s related to swap. I get a 8Gb partition, I dunno if hibernating needs a bigger swap file/partition, as all the system has to be stored and later restored.
Manjaro or Arch wiki ought to have these information… I’m just lazy to check as I would not use it anyway :see_no_evil:

  1. Note the time

  2. Execute:

    systemctl hibernate
  3. Wake up the system.

  4. Note if WiFi is working or not

  5. Execute again:

    systemctl hibernate
  6. Repeat until you have both cases: working and not working. (At least one working and at least one not working)

  7. Provide the output of

    journalctl --system --boot=0  --since "YYYY-MM-DD HH:MM:SS" 

    where obviously --since is the datetime noted in step #1


1 Like

Sorry about this but I have to ask a stupid question(s).

I am fairly new to Linux as I stated.

“systemcttl hibernate” results in “command not found”. If I go into hibernate through “power” will that work for the results you want?

I did it a few times (1 - 3 - 5 mins.) and only the 5 min. resulted in it not working (something timing out somehow?) then I ran the next command and ran into a further problem.

How do you copy the text from Konsole when it runs off the right side of the screen. I mean I know it sounds bad/dumb but normal highlighting of the text to select will not move far enough to get all the text and shortcut combos don’t work either.

Thank you for hanging in there and trying to help. Today’s boot from overnight hibernate took 20 mins. for me to get connected so it continues to be very frustrating.

** Update**

WHoa. Ok now I see this is huge (Page up/down), Duh on my part.

This thing is 2770 lines, and I’m still not sure how to copy the whole thing.

Does seem like maybe this is what you want, lots of fails and then finally a success. I sure don’t know what to look for/at though.

Thanks for reading!

he made a typo it is systemctl hibernate


Thanks I will give it a try. Any idea how to copy that entire Konsole output (off the top of my head 2000+ lines). I must just be missing this somehow.

Hello, @grouchopower has found a workaround for the Wifi issue.
You can find the solution in the linked topic.

1 Like

Hi welcome back,

Now being pretty darn new to linux in general if this is still something I should try 2 1/2 years later on this build, I’m going to have to ask for some instructions.

Not sure what the first line is referring to and/or [device], then I assume that’s something I enter in console after that?

Don’t want to be a pita here but really not much of a clue.

Also one more time, how can I copy the almost 3000 lines of that command that Fabby wanted me to run and report?

Still checking back when I can, once again it took 15 mins or more for the thing to let me in as I type. Works, but VERY frustrating.

Thanks for the heads up and something to look at/into!

Yes you have to create the new file broadcom_wl.conf then copy/paste the 3 mentioned lines.

I created the file with touch command in Konsole then use nano to edit it. But you can also directly create and edit with nano:
sudo nano etc/NetworkManager/conf.d/broadcom_wl.conf

Or you can create the file with touch in Konsole then edit it with Kate in Dolphin.

Anyway, just these 3 lines and a reboot.

In short, it will stop MAC randomization of your device.

As for the logs @Fabby asked, I saw other forum members post log files through a link from a hosting website. If anybody can help?

1 Like

Try if @Falav 's solution works and then we don’t need any logs.

If you still do need to do logs, just maximize your terminal and copy whatever fits in like I’ve stated before:

3 backticks ``` are your friend!


Hi @Falav ,
I think you should read the following post in order to solve the problem as @bogdancovaciu explained very well.
No wifi visible or can connect to any wifi unless I restart my pc - #3 by man

Hope it help, regards.

Ok gave this a shot.

No luck but then again I’m not sure I did this right.

Not familiar with anything you were using but I read elsewhere and gave it a shot. I do now have a document in that file structure with those three lines of commands. Is that all it’s supposed to be or some other form of a file? Your sudo command just returned a “file not found” error message. Step A B C would be great if you have the time. I think I used “touch” at some point but I tried so many thing that I’m not even sure at this point how I eventually ended up with a document file in there with the three lines.

Just took 12 tries to hook the Dang (I’m being nice, really tired of this) thing up.

I will run the other suggestion and post what I can but maybe not tonight (very limited time atm). I just don’t know what good it will be if I can’t get all the way to the right side of the Konsole screen to copy every thing. But he(?) said “copy whatever fits in” so I will give it a shot when I can devote more time to it.

Thank You for your help!

I have to read this new suggestion as well but like I said, Very limited time tonight.

Alright, so type first ls /etc/NetworkManager/conf.d/ and check if broadcom_wl.conf file exists.
If not, create it with sudo touch /etc/NetworkManager/conf.d/broadcom_wl.conf

You can modify the conf file with sudo nano, but if you’re unfamiliar with it, you may go directly to the folder in Dolphin and open the file with Kate.

If it’s not empty, delete all to be sure and paste the 3 lines:


Save the file (it will ask admin password) then reboot.

In the other topic, it has worked for both @grouchopower and I, as apparently it was due to MAC randomization. If it’s still not fixed, you’ll have to try advice above this post, as IPV6 deactivation.