Suddenly cannot enter BIOS, Boot Menu

I’m using Manjaro Kde 23.0.0 on Dell Inspiron 3511. After the last update the grub boot menu suddenly became to appear on start though I only have Manjaro installed. I can’t enter BIOS, BIOS BOOT MENU either. Pressing F2, F12, ESC, DEl will redirect me to grub boot menu.

Tried this command to enter bios, but got no luck.
systemctl reboot --firmware-setup

Also the options showing in grub boot menu is not accessible except the “Manjaro” option which loads into the OS.

Anyone kind to help me, Feeling lost at this point.

No luck, pressing F2 continuously does let me enter BIOS for a split second and then redirect to grub boot menu.

There has been cases over time where this happens with various systems.

I made some notes at one point - now I can add a dell to the list

It could be due to inconsistency in your grub.

When running the Manjaro OS - open a terminal

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi bootloader-id=Manjaro --recheck

As a precaution you should also rebuild your grub config - to ensure the config match the efistub - and update initrd

sudo grub-mkconfig -o /boot/grub/grub.cfg
sudo mkinitcpio -P

Things I have tried so far …

  1. updating/reinstalling grub (no change)
  2. Deleting grubx64.efi, which let me entering the bios, from there reinstalling Manjaro (no change)
  3. Removed the device’s battery[hard resting bios] (no change)
  4. Reinstalling the OS after after hard resetting bios (no change)
  5. Again deleted everything in efi partition which let me entering bios and Installed fresh windows (Problem solved)
  6. Updated BIOS[Dell firmware update via windows update] then Installed Fresh Manjaro(Single boot). (Problem solved)

I had been using my previous installation for more then a year and lost a lot of files, system configuration.

sorry for my poor english, thank you

1 Like

But if your Manjaro system worked - despite the lack of firmware access - you had no reason to reinstall - thus loosing files and configuration?

Firmware can be updated using LVFS: Users

In fact your specific model can be found at LVFS: Search Results

1 Like

Did you try to go into the BIOS with the link in Grub?

Yes, the Manjaro system was working. I lost patience while solving the issue.

I didn’t know firmwares could be updated from linux. :sweat_smile:
Also didn’t know about LVFS

Yes, but didn’t work.

Are you getting to POST (Dell logo display in first few seconds on power-on)? If so, switch off computer. Disconnect your drive, then tap F2 several times at power on to see if you can enter BIOS/UEFI.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.