Sudden crash&reboot with 5.10; with 5.4 not crash, but no graphic

After booting my laptop with kernel 5.10, after a fixed time of 1-2 minutes (laptop and system is fully usable in this time), suddenly the system crashes and the laptop reboots (not like shutting down and reboot, but like pressing the “reset button”). This is reproducible and happens on every (re)boot.

If I select the kernel 5.4 in grub, the laptop is booting and usable without any crash, but the light display manager does not start and startxfce4 doesn’t work, either. So I’m stuck at the command line.

If I boot with FreeDOS or Knoppix 9.1, there is no crash.

The problem has started after an update and opening the setup/efi/bios but changing nothing. Resetting the setup to default didn’t solve the problem. I suspect the Nvidia update to 495 causing the problems. But they also occur if I use the internal AMD Radeon graphic card (I can switch with optimus-manager --switch nvidia, but only with 5.10.79. With 5.4.159, it is not working). If I boot Manjaro, the default is AMD.

I consider downgrading Nvidia driver but Attempting to Downgrade Nvidia Driver; Unresolved Dependencies - #7 by WangGang didn’t say how to do that. The linked wiki page Configure Graphics Cards - Manjaro does not even contain the word “downgrading”.

I have a GeForce GTX 1650 Ti Mobile and a AMD/ATI Renoir VGA controller checked with lspci | grep VGA

Have you tried the solutions provided in the Stable announcement?

In the solutions there seems to be no problem that seems to be related to mine.

The solution for Xorg crash did not work. All the values are already at 1.00000. [Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa - #244 by LS650V

[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa - #246 by cantoraz seems not to be related because there is no “Xorg” or “coredump” in journalctl -k log.

Nethertheless, I tried to downgrade Xorg. But if I enter downgrade xorg-server and select an old version, I get conflicting packages (xf86-input-elographics, xf86-input-evdev, xf86-input-void,xf86-video-amdgpu etc). Are they safe to remove?

EDIT: The “old version” is 1.20.13.

Downgrading the Nvidia driver to 470 does not help at all.

No, you would have to downgrade those too.

I try downgrading xorg-server, but strangely I do not have the required packages available in the cache and some are missing. @cantoraz Could you post yours for downloading?

Currently I try to fix Sudden crash&reboot with 5.10; with 5.4 not crash, but no graphic - #3 by kangaroo and maybe downgrading xorg and the relating xf86 packages is a solution…

I know there is a repository for old Arch packages butAFAIK they can differ to the packages from Manjaro so it would be safer to use yours.

In my cache:

  • xf86-input-elographics-1.4.2-2-x86_64.pkg.tar.zst
  • xf86-input-evdev-2.10.6-2-x86_64.pkg.tar.zst
  • xf86-input-libinput-1.2.0-1-x86_64.pkg.tar.zst
  • xf86-input-void-1.4.1-5-x86_64.pkg.tar.zst
  • xf86-video-amdgpu-21.0.0-1-x86_64.pkg.tar.zst
  • xf86-video-ati-1:19.1.0-2-x86_64.pkg.tar.zst
  • xf86-video-intel-1:2.99.917+916+g31486f40-1-x86_64.pkg.tar.zst
  • xf86-video-nouveau-1.0.17-1-x86_64.pkg.tar.zst
  • xorg-server-1.20.13-3-x86_64.pkg.tar.zst

I put those in one tarball:

Good luck with you.

@cantoraz If I click on that link: The file you requested has been deleted

Maybe someone else can send me the files? They should be in /var/cache/pacman/pkg/

You should troubleshoot and fix the issue instead of trying to get old packages from other people to downgrade. Open a support thread.

This post already includes a link to a support thread. I’m posting here, too, because it is an issue that is related to this update.
IMHO downgrading is one possible thing you can do in troubleshooting: If it is working afterwards, you can use the computer again and you know which software causes the issue. This information could be helpful to solve the problem with the most current packages, too.

I tried downgrading using DOWNGRADE_FROM_ALA=1 downgrade [..], but there is always a conflict with libxvut, even if I downgrade that library, too.

If I remove all Nvidia drivers with mhwd, the problems (crash on 5.10+ and no graphic on 5.4) are still there. So the Nvidia driver did not seem to be the cause of the issues.

The Manjaro live cd is working. So I’ve reinstalled the whole system with Manjaro and after booting, there is no graphic.

Because I didn’t manage to fix this important issue, even with the help of the Manjaro community, I decided to switch to another Linux distribution that is more stable. The caveat is that stable distros often have old software. But with Flatpak and Snap this problem (hopefully) can be circumvented.

PS: I took this decision before the most current stable update came available ([Stable Update] 2021-12-10 - Kernels, Systemd, LibreOffice, Plasma, Browser, Thunderbird - #2 by philm), so I do not know if this could fix this issue.