Subtitles with low opacity or opaque in all media players

Hi, I have a problem with the subtitles in all the media players.
I tried with mpv, vlc, smplayer and I have the same problem with all of them.
I tried to change the configuration in every app but always I continue watching the subtitles caption in “grey” or opaque and with less opacity. For example I want the font color in YELLOW or WHITE (strong white) and continue like this:

It’s too weird, in the beginning I was thinking was a problem with mpv but then when I downloaded all different apps and have the same problem I said it’s time to write here.

Hope you can help me, thanks!

smplayer can use mpv or mplayer as a backend
I’m not familiar with vlc (I don’t like it and don’t have it installed) but I suspect a similar situation.

So, you’d need to check (or possibly post) the contents of the configuration files for each one player.

I only have mpv installed - and it’s configuration file is in /etc/mpv (system wide)
and in ~/.config/mpv (per user)

Unless and until you provide actual data, no one can do more than wildly speculate.

No issue here with VLC:

Click on Tools at the top menu bar. 
Choose Preferences from the list. A new window will open.
Go to Subtitles tab. Click on Position and choose the 
position that you need from the list. It can be center, left, right, bottom and more. 
Go to Subtitle effects block. Click on Font and choose the font 
that you want from the list. 
Click on Font size and choose the size that you need from the list. 
You have a choice of auto, small, smaller, normal, large and larger.
Click on Text default color and choose the color that you want 
from the list. 
Click on Save to apply the changes.

is mpv.conf

… what did you try to accomplish with this command?:

I typed “is”; the capital letter looks like a “L”.

ok, of course Is is not the same as ls
the latter is the name of a command, the former … is not
The question is still the same:
What did you try to accomplish with it?

It miss the extension “.conf”: https://github.com/mpv-player/mpv/blob/master/etc/mpv.conf

These two above are directory names.
Directories contain files.
(or other, yet more, directories)

Files have extensions (but not always - they don’t have to …).

ls -hl /etc/mpv
or
ls ~/.config/mpv

will be listing what is inside these directories
… what files are below that directory / what files are inside it

Sorry. I overlooked.

Sorry, here is my laptop:

OS: Manjaro Linux x86_64 
Host: GM6PX0X Standard 
Kernel: 6.6.16-2-MANJARO 
Uptime: 2 mins 
Packages: 1485 (pacman), 32 (flatpak), 13 (snap) 
Shell: zsh 5.9 
Resolution: 1920x1080, 1920x1080 
DE: Plasma 5.27.10 
WM: KWin 
WM Theme: Sweet-Dark 
Theme: [Plasma], Sweet-Dark-v40 [GTK2/3] 
Icons: Sweet-Rainbow [Plasma], Sweet-Rainbow [GTK2/3] 
Terminal: kitty 
CPU: 13th Gen Intel i9-13900HX (32) @ 5.200GHz 
GPU: NVIDIA GeForce RTX 4060 Max-Q / Mobile 
GPU: Intel Raptor Lake-S UHD Graphics 
Memory: 2010MiB / 64039MiB 

And yes I added changes in ~/.config/mpv but in all the apps are the same mode.

No idea what you mean by that.
You certainly didn’t mention “all the apps” or “all the apps are the same mode”
… whatever information you meant to convey by saying that …

there is nothing in here that could contribute to resolving whatever issue you have

What is the issue? (subtitle transparency or color?)

How did you try to resolve it?

or even try to assess the current situation
… by reading the config files …

I think you are not reading correctly my post.
I wrote in the first post the things that I tried and the apps that I downloaded and tried.
smplayer, mpv, vlc. And also I uploaded a screenshot to show the subtitles.

I have checked all the configurations files and also I edited some of them or also directly with the UI (VLC and SMPlayer).

If you see the screenshot you can see the letters are not clear and also I tried to change to YELLOW in ALL the apps and always is showing like the screenshot.

In all the apps I have this:

and I want this:

Can you see the difference between the subtitles? The first one is not pure WHITE. And I have this problem in all the apps leaving the config by default or trying to modify some options.

Thanks

The subtitle likely has its own styles defined.
In mpv press u to toggle override.

Thanks for try to help.
Nothing changed. I can see at the top the option changing but the subtitles continue like my pictures in the last posts :frowning:

I think is something in the laptop and is not in the software, because in all the apps it’s the same.

Run with mpv --sub-color="#FF0000" vidpath.
Subtitle should be red.
If not press u and toggle it to force.
The next subtitle should be red.

Thanks for continue trying. Doesn’t work.

And mpv was opened with the movie but the subtitles are like my screenshot. I pressed u and nothing too :frowning:

Mostly I just go with MPV, but for settings, it’s very hard to beat Haruna - basically MPV in a KDE package - so that means great settings and much nicer to use than VLC:

If you can’t read that, you’re in REAL trouble :wink:

Since it is srt, it cannot have its own styles, specifying sub-color would override the configs, so not that either.
Warning message indicates a script to be outdated in the future, but those would not affect VLC.
I wonder if mpv --sub-color="#FF0000" --vo=kitty vidpath would change anything.

I will try it too @Ben. If I have the same color like the other 3, I will kill me hahaha :rofl:

@wntr I tried the video was reproducing very very very slow in my kitty terminal but no subtitles appearing. I dragged an dropped there but doesn’t show any subtitles in this case.