Subtitles not working on VLC or Totem

Hi y’all, I’m using Manjaro Gnome (with the latest updates) and I’m experiencing an issue with video subtitles. When I open a movie with VLC or Totem (the default Videos app) and load the SRT file, the subtitles won’t show up… The subtitle track appears as selected, but no text is displayed. The subtitles are in English.

The weird thing I noticed on VLC is that when I open the movie, it does show the file title at the bottom, and even weirder, it did show the subtitle “watermarks” every once in a while, something like “Subtitles made by” or whatever…

I tried changing the subtitle font on VLC and the issue persisted… The default one is DejaVu Sans, which I assume I have installed.

I don’t think I’m the only one having this issue, if any of you could suggest something I’d be really grateful. Thanks!

Hello and welcome,

Subtitles working perfectly fine on my end. We have no way to check the source of your files and how got made, what encoding was used and so on.

That would have to be confirmed tho, so please try other players too and see if the issue persists, even try a live media session, or different OS, or ask some friend to check the same files on their end. :slight_smile:

Thank you for your answer. I will try some of your suggestions and investigate more, if I can fix it I will let you know, just in case anyone else is having the issue. :smile:

Marco did you try a clean install to see if it makes a difference?

Did you check that the subs file really had all lines of the conversations and not only the publicity?

Hi guys, the issue is solved. A couple of days ago I booted from a live USB to check if I had the same symptom, but everything worked fine. Then I removed the USB and booted normally, my idea was to save my files and reinstall, but there were many packages to update… After the update my subtitles started working… Didn’t even have to reinstall, so that’s great. I assume the update fixed the problem.

Anyway, thank you all for your comments and suggestions, I’ve been using Manjaro Gnome for only a couple of months and I’m really happy! I will mark bogdancovaciu’s as the solution so the thread doesn’t stay unsolved.

Cheers! :grin: :beers:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.