Sublime text won't open without sudo

I installed sublime text 4 with

sudo pamac install sublime-text-4

Everything went well but when I tried to open sublime text with subl as a normal user nothing happens, I have to use sudo subl to open sublime text. How do I open sublime text as a normal user?

[manjaro@manjaro ~]$ pidof subl
[manjaro@manjaro ~]$ subl -v
Sublime Text Build 4142
[manjaro@manjaro ~]$ subl
[manjaro@manjaro ~]$ 

Don’t use sudo with pamac.

You could remove the settings: rm -r ~/.config/sublime-text-3

(It might be -4, for me it’s -3).

On another note: It is proprietary software, you should contact the developer for support.

1 Like

I suggest using sublimetext official repo

1 Like

And learn proper commands, even if Pamac corrects your mistake, you use build and not install for AUR packages.

1 Like

They should learn proper commands, however, if AUR is enabled, you can do install for AUR packages.

So allowing people to run it with sudo, allow to interchangably use different commands… makes so much sense, especially when you mix in noobs that use it.

1 Like

If we talk semantics, the “build” name is weird because it doesn’t just build but also install. Something like “install-aur” or similar would be better.

I don’t see a conflict for noobs. They shouldn’t enable the AUR anyway.

“build” name is fine. You just have to stick to what it does, same as to what “install” does. But in this case I guess logic was “oh but if a noob writes “install” instead of “build”, let’s check if this is actually an AUR package and lets build it anyway”.

Well, now you can understand why in arch repo there is only pacman.

Anyways, this is a bit offtopic, so … :person_shrugging:

Doing this and then restarting my PC solved the problem, thank you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.