Stuttering in Death Must Die

Hello, everyone!

I’d like to ask for help with troubleshooting this problem. I notice that when playing Death Must Die, my frame rate isn’t as smooth as when playing other (even more demanding) games. This laptop is the same one I used for playing all sorts of games on Windows, with the smoothest performance. I don’t really know why this happens when playing in Manjaro, though… can anyone help, please?

Here’s my system info:

  Host: ROG-Laptop Kernel: 6.6.10-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.10 Distro: Manjaro Linux
  Type: Laptop System: ASUSTeK product: ROG Strix G733QR_G733QR v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: G733QR v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: G733QR.331 date: 02/24/2023
  ID-1: BAT0 charge: 68.9 Wh (100.0%) condition: 68.9/90.0 Wh (76.6%)
  Info: 8-core model: AMD Ryzen 9 5900HX with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 1639 min/max: 400/4680 cores: 1: 400 2: 400 3: 3048
    4: 400 5: 2901 6: 400 7: 2914 8: 400 9: 2297 10: 400 11: 2580 12: 2739
    13: 400 14: 400 15: 3550 16: 3010
  Device-1: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] driver: nvidia
    v: 545.29.06
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Display: wayland server: v: with: Xwayland v: 23.2.3
    compositor: kwin_wayland driver: X: loaded: amdgpu,nvidia
    unloaded: modesetting,nouveau dri: radeonsi gpu: nvidia,amdgpu
    resolution: 1920x1080
  API: EGL v: 1.5 drivers: kms_swrast,nvidia,radeonsi,swrast
    platforms: gbm,wayland,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.3.3-manjaro1.1
    renderer: AMD Radeon Graphics (radeonsi renoir LLVM 16.0.6 DRM 3.54
  API: Vulkan v: 1.3.274 drivers: nvidia,radv surfaces: xcb,xlib,wayland
  Device-1: NVIDIA GA104 High Definition Audio driver: snd_hda_intel
  Device-2: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
  Device-4: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  API: ALSA v: k6.6.10-1-MANJARO status: kernel-api
  Server-1: PipeWire v: 1.0.0 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp2s0 state: down mac: 50:eb:f6:49:0d:d6
  Device-2: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e
  IF: wlp3s0 state: up mac: 34:6f:24:57:f2:63
  Device-1: IMC Networks Wireless_Device driver: btusb type: USB
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 3.68 TiB used: 46.49 GiB (1.2%)
  ID-1: /dev/nvme0n1 vendor: KIOXIA model: KXG60ZNV1T02 NVMe 1024GB
    size: 953.87 GiB
  ID-2: /dev/nvme1n1 vendor: Intel model: SSDPEKNU010TZ size: 953.87 GiB
  ID-3: /dev/sda vendor: Toshiba model: MQ04UBD200 size: 1.82 TiB type: USB
  ID-1: / size: 928.86 GiB used: 36.83 GiB (4.0%) fs: ext4 dev: /dev/nvme1n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 296 KiB (0.1%) fs: vfat
    dev: /dev/nvme1n1p1
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme1n1p3
  System Temperatures: cpu: 64.6 C mobo: 48.0 C gpu: amdgpu temp: 54.0 C
  Fan Speeds (rpm): cpu: 0
  Processes: 374 Uptime: 2h 22m Memory: total: 32 GiB note: est.
  available: 30.77 GiB used: 9.02 GiB (29.3%) Shell: Zsh inxi: 3.3.31

Thank you.

i suspect your on wayland and on internal i-gpu that won’t deliver the real performance of your system. check

echo $XDG_SESSION_TYPE && glxinfo | grep server

post the output, use the option of preformatted text and paste it in

It turns out you’re right!

server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:

so, now what do i do?

You should first go back to an X session instead of a WAYLAND session as you’re using NVIDIA.

See if you have same issues under the X session, then fix the issues and stay on the X session anyway.

I don’t understand what that means… how do I do that?

You need to select X11 at login screen with sddm.

Thank you so much =) this solved the issue.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.