Stuttering and tearing in videos (nvidia - kde)

You did install the video driver trough mhwd, right? Since Manjaro is using it, then that is the default: /etc/X11/mhwd.d/nvidia.conf
Nothing else.

That is not why i mentioned my older GPU, you twisted what i meant by that, but i will not explain it …

When KDE Plasma 5.20 will hit stable and you will have all this options in Compositor Settings, you might still need to tweak the nvidia.conf


1 Like

If you are then it is not a normal Nvidia installation from Manjaro.

Nothing seemed normal for me with the last big explosive update tbh, I reinstalled the drivers the better I could. Still it works, and it uses xorg.conf, so I don´t know why that would be causing a bit of stuttering in videos.

My nvidia.conf file is empty, I suppose that the system uses it only if it has something on it, if not it uses the xorg.conf.

Exactly the same behavior after applying this settings and reboot…

Finally I tried writing your example in both, xorg.conf and nvidia.conf, it applies in nvidia-settings, but still no improvement in performance.

Well thanks for the help, I suppose that I will keep waiting for some update to magically fix whatever happens with my system, since this seems to be related to something very weird, probably the kernel or the drivers or idk, but nothing I can do to fix it myself.

Thought to add it in the third place? :slight_smile: Use one or another, and to be sure is loaded you have to make this command

to point to that place.

Check what drivers you installed.
mhwd -li
Always use mhwd for kernel and drivers.

1 Like

I have video-hybrid-intel-nvidia-prime installed.

Also I just checked with a xfce session and the problem is not there (but when playing videos in xfce another problem exists, if I move a window while playing video the window moves veeeery laggy).

Anyways it seems to be kde´s fault after all.

Also, I do use mhwd when I have to do something related to kernel or drivers, it´s not like I go to some webpage and download them from there. I think that my xorg.conf file is weird because of the last big update.

I guess it is time to start from beginning then as everyone should when opening a support thread, missing critical information leads to waste of time:

You could have tell me what information did I miss…

If you mean the drivers… I had nvidia drivers (not prime) before manjaro update, and as I said, the problem was the same. It´s a problem I´ve been having for a long time with lots of configurations done.

Also the prime installation was done automatically by mhwd as the recommended drivers, and I don´t use the igpu, I don´t have any screen connected to it and all the desktop rendering is done by nvidia.

This topic gets hilarious by the time it reveals more information … So, after KDE plasma now you mention

Your user profile states you have GPU: Nvidia GTX 1060 6GB - and if that information is correct, there was no reason for me to think to hybrid graphics hence no hybrid drivers.

MHWD will not install hybrid drivers if there is no iGPU detected. Start with your BIOS and disable the iGPU, install the proper drivers video-nvidia, then start tweaking …
Mixing KDE Plasma with XFCE on the same user is a very bad idea …

I’ll let others to deal with it. Cheers!

So cruel XDDD

Well I´ll try to extract all the information I can from the whole conversation and try to guess what could be happening.

Thanks for the help anyways.

If you want pure Nvidia setup, as suggested, disable your integrated Intel GPU in Bios so Manjaro can handle it correctly.
If you do not disable your Intel GPU in BIOS then you probably need the hybrid configuration installed properly through MHWD or Manjaro Settings (graphical UI).

Start over, just configure BIOS as you want it, then remove and reinstall properly the appropriate driver through Manjaro tools (I recommend the graphical interface it is easy no need to type commands).

1 Like

Do you think that the problem could be related to hybrid drivers? even if I had the same problem with the other drivers and I don´t have the problem in xfce? and even if when I check the desktop renderer it´s all nvidia?.

Anyways I do want a pure nvidia setup, I´ll try to reconfigure the bios some day (I don´t think I know how to do that now).

Honestly I’m not sure what is going on in your system. In your situation I would wipe it all clean, then start over.
From BIOS check if you can disable the iGPU if you do not want to use it at all, then removing/reinstalling, WITH the tools Manjaro provides, the appropriate driver. If you install normal Nvidia drivers my method should work. If you use Hybrid drivers then I’m not sure the best way to configure it for best experience but at least you would have clean installation to start tinkering.

1 Like

The thing is that I don´t know if I will need Quick Sync some day for some task, so I didn´t go for a pure nvidia system yet because of that. But probably your solution works if I install nvidia drivers with no hybrid drivers so I should try it too (even if my previous state was exactly that and I had the same problem, but maybe now it works).

Thanks for the help.

Then you should use the hybrid drivers, which makes use of the Intel iGPU and can offload work to Nvidia on demand, if I’m correct. I think it can not always work with just the Nvidia drivers with an hybrid setup (which is what you have if you have the Intel iGPU enabled).

1 Like