Stuck on "Reached target graphical interface" when booting from live USB

So I feel sort of stupid now, it had to do with the drivers and linux kernel I was using. The initial problem was “solved” (more circumvented) thanks to @6x12 which is why I marked their answer as solution. This allowed me to install Manjaro and get a graphical interface. After booting (via Intel graphics) I updated the system via pacman -Syyu and after this it would no longer boot using either the nvidia card or the intel card. I could still access a terminal using ctrl+alt+f2 using the Nvidia card connection to my monitor.

After a lot of hassle and failures to install things using mhwd -a pci nonfree 0300 I was about to give up, but found another post here here. This is where it finally clicked, they looked into which linux kernel was used. I found out I was trying 6.1 (the system had updated me to it).
Now I have installed and selected 5.15 LTS (as one should) and it works again!

Thanks all for the help and insight, cheers!

I'm sorry if I'm not supposed to post this on these forums due to Cinnamon being a community version, but I do not know where else to turn.

Whilst awaiting an answer I’m trying to see whether main branches such as KDE also result in this problem.

I am trying to boot a live USB stick with the latest Manjaro Cinnamon ISO. Booting seems okay, I get to choose with which drivers I want to boot and both end up in this terminal-like output state where it attempts to reach all manner of hardware devices. Finally it ends up at the graphical interface, to which it says [OK]. And then just stays there indefinitely.

  • I’m using Ventoy to boot the ISO
  • I’ve disabled secure boot
  • I am not using windows fast boot
  • I have set the preferential GPU to my RTX 4070 TI and to always use that GPU rather than intel HD graphics.
  • AHCI is enabled

Might this just mean that the drivers are not up to date yet for this graphics card?
I’ve also tried to update the entire system via ctrl+alt+f2 and updating via pacman, but after sudo systemctl reboot I feel like those potential changes are gone again due to it being a live USB.

I’m sort of at my wits end here, if anybody has any ideas, please let me know!

Thanks in advance,

Maybe set this to Intel to start with since it should work without issue with the included drivers. After installing the proprietary drivers you should be able to set to hybrid/nvidia.

Hi and welcome to the forum :+1:

Did you try the forum search yet?

There is nothing anyone can help you with when they don’t know your specific hardware:

If you set the usb as efi this is why try mbr instead.

I used mbr I think, so i’m afraid this is not the problem?

This seemed to work, I could install the system, but after updating the system I can no longer get any visual. I can still access the system via ctr+alt+f2

Any tips on what to setup and install, maybe via mhwd?

I’m sorry I’ll provide the results in my original post in a bit. I definitely looked at other posts first, that’s why I included most of the things I tried already. They were all suggestions from different posts where people had the same problem, but to no avail to far. :slight_smile:

Hello @Mantsje,

if you dont use the internal intel graphic card, try to disable it in BIOS/UEFI.

And when it says “Reached target graphical interface” the system should have booted. So you can try to get to console(TTY) via CTRL-ALT-F2.

After login you can try to install nonefree nVidia driver or get system information like @TriMoon said.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.