Stuck on "Reached target Graphical Interface" after GPU swap (RX 6650 XT)

Hi, I have a bit of a problem. I’m on Manjaro KDE Plasma kernel 5.15.65-1 and I’m trying to swap a GPU. System fully updated on the testing branch. Old GPU is GTX 2060, new GPU is RX 6650 XT. When I try to boot with the 6650, I don’t get past the “Reached target Graphical Interface” message. The GPU itself is good, I tried it in a Windows PC and it works. Does anyone have an idea what might be wrong, please?

One thing I should probably mention. I didn’t uninstall the proprietary nvidia driver. Do I need to do that?


you should remove the nvidia drivers - and re/install the video-linux drivers …
you can do it from the stuck screen, enter into tty: ctrl+alt+f2 or f1-f6 keys, enter your username/password and use commands … if you dont know commands, post output from this command here:
mhwd -li

Thanks for the reply, I’ll go try it.

Ok so the mhwd -li lists “video-nvidia 2021.12.18”. Well even I can see that this is not right. This is the one I’m probably supposed to remove, right?

yes remove it:
sudo mhwd -r pci video-nvidia
then install this:
sudo mhwd -a pci free 0300
systemctl reboot

Did that, but still stuck on that screen…

mhwd now says video-linux 2018.05.04.

But inxi now says "Driver X: loaded N/A gpu: amdgpu

Is this correct?

It also says “with: Xwayland”. I was on X before the switch, I could never get Wayland working.

maybe there is some conf that is causing it, provide output from:
find /etc/X11/ -name "*.conf"
and under inxi -G check this:
Display: x11 - if it shows this you are on xorg


It shows: Display: server: X[dot]org v: with Xwayland v.22.1.3 driver: X: loaded: N/A

(previously it said loaded: nvidia)

the only one that could cause is the xorg.conf so remove it:
sudo rm /etc/X11/xorg.conf
so you are running xorg
systemctl reboot

It works! You’re the best, thank you. I love this community, always so helpful!

I took a look into that xorg.conf file before deleting and there were some nvidia-related settings there, so that was the problem. I’m just including this if someone ever comes across this post.

So I’m marking this as solved, thanks again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.