Stuck on login screen with no password prompt

When I turn on Manjaro Deepin, the login menu appears with no way to put in a password, only a blue button with an arrow on it. Pressing the button does nothing.

Switch to TTY and make sure the system is fully updated:
sudo pacman-mirrors -f5 && sudo pacman -Syyu
reboot the system after that with
systemctl reboot

That did not work. If it helps, this started happening after i enabled logging in without password.

Then you know what you have to do.

I would suggest rolling back your change then have a look into the docs for anyone with a similar issue.

Do you know what window manager you are using?

If I knew how to roll it back, I would. I’m using DDE (Deepin).

I had the same issue. I just rebooted, and my login popped right up. I did my updates and had no issues after that.

Huh. I’ve rebooted about 10 times already, nothing changed. I’ve done my updates, nothing changed. Maybe yours was broken for a different reason?

… but you enabled login without a password
So you know how you did it.
Just reverse the change you made?

The problem is me not knowing how to get into the settings to reverse said change.

But you could describe what you did.
I do not run/have Deepin - but describing what you did could be a clue nonetheless.
Especially to those who do know it.

You sit at your computer - everyone else relies on your most accurate description of the situation.

… did you just set an empty password?
don’t know whether that would even be possible

Can you switch to a TTY (of course you can)
and log in there?

I am using Manjaro, with the Deepin desktop environment.
In the Manjaro settings, i turned on logging in without password. It should be in the account tab.
I can log in with a tty and have been doing so for the past few days.

In the Manjaro Settings there is no such setting, neither in the Accounts Tab nor anywhere else.
The only thing one could do in the Accounts Tab is to set an empty password.
(I didn’t try whether that actually succeeds)
… so it is for me, on Xfce - but the Manjaro Settings App is the same for every flavour/DE

with or without a password?
Have you tried to set a password for your user?
the command is simply:
passwd $your_username
in TTY, when logged in

passwordless login (via display manager into your graphical session) is not the same as having an empty password/no password at all
the former is not a good idea - it will only lead to being asked the password later on (yes, even if it’s empty) or stuff randomly not working
the latter … even less so

Oh, I sent it to passwordless login.

As I said - that’s not possible.
The only thing you can do there is:
set an empty password

If you did that - just set a password again.
the command is:
passwd $your_username
or just:
if you are already logged in via TTY

Then maybe my goldfish short term memory made a fool out of me again. I’ll try that in the morning, when I can use the PC again.

It didn’t work. The login screen is still the same as before. If I could send images, I would.

You know, you are rather stingy with the amount of information you give away. :wink:
But I also understand that it is hard if you used some GUI and now cant remember what you did and now can’t go back to re-trace your steps.

What did you do that didn’t work?
What did you expect - what happened instead?
Do you still have to supply a password to log in to TTY?
I think yes, but I could be mistaken.

You could create another user account and see if you can use that.

Passwordless login/bypassing the display manager without having to supply a password usually works by modifying some Display Manager configuration file.
These reside in /etc/something - I don’t even know what the Display Manager’s name is in Deepin and couldn’t suggest where to look.

Can’t you use the thing you installed from to see what you did - just to refresh your memory?

1 Like

What did you do that didn’t work?

I turned on something in the Accounts tab that was meant to make me not need to put in my password to log in (only I use this PC)

What did you expect - what happened instead?

I expected to not need to put in my password anymore to log in. Instead, I got a dysfunctional login UI with a single → arrow that does nothing.

Do you still have to supply a password to log in to TTY?

Yes, that still works as intended.

I’m on my Windows partition right now, so I’ll go ahead and try what you suggested (creating another user account).

It worked! Apparently, I turned on both automatic login AND login without password. Now I can use Manjaro normally again. Thanks!