Stuck on /dev/sda5 clean

Hi. I installed manjaro on my computer a while ago and after windows failed to install grub would not boot. It just gave me a grub rescue prompt. After trying and failing to reinstall grub I found that if i used the “Detect EFI bootloaders” option in the installer menu that i could get into grub. However now i am getting a different issue. Manjaro would hang on “dev/sda5 clean” when trying to boot. I saw other people who had the same issue and reinstalling their video driver fixed it however when I tried that it didn’t work. I am using an intel core i3 CPU and an AMD RX 580 GPU. Any help?

How did you try that?

Are you interacting with the system via chroot ?

(just in case heres a link)

From there maybe you can

  1. Make sure to be up to date:
    sudo pacman-mirrors -f && sudo pacman -Syyu
    (be sure to share any errors you might encounter)

  2. Share with us some system info. The 2 following links might help:
    How to provide system information
    How to use public command line pastebin services without installing anything
    It might help to provide mhwd output as well:
    mhwd -l -d