Stuck on clean... files... blocks in one kernel but not in other

Hello. I have Manjaro KDE. I had some hardware issues on my pc where it turned on but without showing video. I had to turn it off using the physical button some consecutive times while trying to fix the issue.
After I fixed the issue my pc booted, but got stuck at clean… files… blocks. At this point the cursor, already with its Plasma theme, appeared and moved, but nothing more loaded. I booted from a usb stick and did fsck, that did not return any issue. After that it got stuck again but without displaying cursor.
After some testing I found out that if chose kernel 5.15 in grub everything loads correctly but if I choose kernel 6.0 (that worked before this issue) my pc gets stuck.
I booted with kernel 5.15, uninstalled 6.0, rebooted in 5.15, installed 6.0 again, rebooted and even this way, got stuck again using kernel 6.0.
So I uninstalled kernel 6.0, kept using kernel 5. 15 and everything is working.
However, how will I be able to update to future kernels if I don’t fix this issue? And how can I solve it?

Maybe you misunderstood here something. Kernel 6.0.5 is considered to be stable, but that doesn’t mean it works everywhere and is well tested. LTS kernels are meant to be used for production and only if you really need a STABLE kernel (hardware support for example) consider to use it. So better call it a stable work-in-progress kernel.

Anyway… kernel 5.15 goes Oct 2023 EOL and kernel 5.10 on Dec 2026. There is plenty of time until you have to update. LTS kernel don’t get any major updates, but still get security patches and bug-fix patches.

The Linux Kernel Archives - Releases


Gentle shut down a suddenly hanged PC to minimize a chance of getting a broken filesystem and data loss:

If kernel 6.1 does work for you (in the future), you don´t need to go over 6.0 :wink:

1 Like

Thank you for the explanation.
It’s not a problem to me if I have to keep 5.15, skip 6.0 and wait for a next lst release. But my worry is that, if 6.0 was working and now it’s not, future versions might not work as well. So if someone could help me figure out what is happening and how to solve it, I can avoid headaches in future releases.

Oh man :roll_eyes: 6.0 is really new and it needs to get more mature. I am not a kernel dev and cannot tell you what changed exactly, but it doesn’t mean it will not work for future versions. Stable kernels get bug fixes from the mainline kernel and maybe a bugfix introduced a bug on your system. That happens :man_shrugging:

Unless you want to contribute to the mainline kernel, it would not make any sense to go the extra mile. Likely the issue is solved on the next patch. But you know… you can investigate the journal for example…

1 Like

if you want to read the simplified summary about the changelog of Kernel 6.0 including git commits, here:

1 Like

Ok. Thank you all. If I don’t find a solution I will wait.

I think you have found the solution, use a LTS kernel. Kernels are mainly for hardware support. Newer kernels support newer hardware, but sometimes introduce bugs to existing hardware. Unless you need a newer kernel to support a specific piece of new hardware, stick to LTS kernels.
Why didnt 6.0 work the second time? Its possible that a newer version came out between your uninstalling and reinstalling that introduced new bugs, or it might have been a bad install. New kernels are under heavy development and sometimes bugs get in.
In any event its a good idea to have 2 kernels installed in case of bugs or a bad upgrade When moving to a new kernel leave the old one in place as you did. Way to often people remove the old one to fast.