Stuck on boot screen, but can access tty

For some reason when I last logged out of the system, it shut down the system and on booting it’s giving me this, and is stuck here with no signs of progress.

However I can access the tty2 and tty3 and it seems to work atleast. What can I do?

I did check this post:

and my graphics driver seems to be there with no issues.

if you are stuck at boot screen you should look into your gpu settings

What exactly should I look into? I’ve tried reinstalling my nvidia drivers through tty and it was of no help.

It doesn’t make sense tbh, i was using it just fine, logged out of manjaro but it shut down and on restart it is stuck on boot.

check your kernel parameters - especially the part of enabling kms

Please see → Black Screen with Plymouth - Cause and Solution

I’ve made the pastebin entry as suggested in that post but not really certain what to do after that.

If you removed splash from /etc/default/grub and plymouth from /etc/mkinitcpio.conf, the (HOOKS)-part, plymouth should be dormant, not messing up your boot. Run the 2 commands

sudo mkinitcpio -P

sudo grub-mkconfig -o /boot/grub/grub.cfg


Up to you if you want to remove Plymouth from disk.

Will it affect my windows dual boot?

Update: I tried doing this, but it’s still getting stuck at the same place. Maybe it has nothing to do with Plymouth afterall

I put amdgpu in MODULES=() and kms in HOOKS=() and it still doesnt seem to do anything.

Might just have to fresh install again, i can backup my files

See what @linux-aarhus posted - in the first post of the linked thread:

Black Screen with Plymouth - Cause and Solution

For Nvidia

A single kernel argument may be enough nvidia_drm.modeset=1

Login via TTY, and remove Plymouth.

Plymouth often can play havoc with boot processes. Many (myself included) will remove it even if it isn’t causing issues.

The correct method to remove it can be found here Manjaro Plymouth under the heading of REMOVAL.

I’m afraid it’s not as simple as uninstalling it.

I hope this helps. Cheers.

This didn’t seem to work, neither did disabling Plymouth. after disabling Plymouth it was just stuck on this instead

I get this message at every boot even before it was getting stuck at boot

Is /dev/nvme0n1p5 an NTFS volume?

Also, logs would be more useful than screenshots.

I’m guessing you might have an issue with your mount options for that volume; maybe double-check your /etc/fstab :man_shrugging:

Im only taking photos because i cannot send the logs, i cannot login.

That NTFS partition is not a problem anyways, its my dual boot windows partition which i need to modify in fstab. Dont think it is related to this issue, it has always been there in the boot messages

Well, it that’s what it’s choking on, I dare day it’s a problem now.

It’s not even similar to what you first posted - this is failing right at the start.

We can’t see what you can see - photos don’t help much.

inxi -zv8

will contain everything in great detail

Fortunately … I have no experience with Nvidia Graphics and can only repeat what I have read from others.

I am sorry, i meant this is always the first message that comes in the boot sequence for manjaro, in the first image I sent, it is overwritten.

Output of inxi -zv8:

One thing I’ve missed out on saying is before it gets stuck here, it flashes 3 times

This is not visible in the system info you just posted:

  Kernel: 6.1.85-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: hpet
    avail: acpi_pm parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=f48d994e-c928-4379-8442-a607bddaabd8 rw quiet udev.log_priority=3

… you removed it again because it did not work?

i only tried it temporarily using the grub cmdline. I had some other work irl so i didnt bother putting it in /etc/default/grub

Update: I’ve put it now

Okay i tried starting a wayland session by just doing startplasma-wayland and i can succesfully enter into my desktop. But surely there must be a fix without needing to do these workarounds.

Btw here was the last thing i was doing on my pc, before this happened: GitHub - dianariyanto/virtual-display-linux: Create virtual display / monitor on linux OS for extended display via teamviewer or vnc server without any real Monitor is Plugged In.
It could have something to do with it

I was right, It had everything to do with it. Further more reason to never blindly run a script from anywhere.