Stuck on boot (graphics issue?)

Hey everyone, I’m currently not able to boot fully - this (or something extremely similar) happened several months ago, and was related to a graphics driver issue, but I can’t remember how I fixed it. I did just install or update something Nvidia-related yesterday, so I assume that’s messed something up, but of course I can’t remember if that was the driver, or something CUDA-related, or what.

If I choose Edit Boot Options and remove the Quiet option, the system stops booting at Finished TLP system startup/shutdown. I can Ctrl + Alt + F2 to log in, and get the following info:

Manjaro version: 22.1.1 Talos

Kernel: linux62-rt

inxi -G

GTX 970
driver: N/A
with: Xwayland
v: 23.1.1
loaded: N/A
failed: nvidia
gpu: N/A
tty: 128x48

mhwd -li -d

NAME: video-linux
VERSION: 2018.05.04
CLASSIDS: 0300 0380 0302

NAME: video-nvidia-470xx
VERSION: 2023.03.23
CONFLICTS: video*nvidia*
CLASSIDS: 0300 0302

Troubleshooting steps: I removed the video-linux option, but that didn’t seem to help, so I installed it again. I tried to remove the video-nvidia-470xx option, but got the following error:

failed to prepare transaction (could not satisfy dependencies)
removing nvidia-470xx-utils breaks dependency 'nvidia-utils' required by cuda
removing nvidia-470xx-utils breaks dependency 'nvidia-utils=470.183.03' required by nvidia-470xx-dkms

Does anyone have any next steps I can try?

first remove nvidia-470xx-dkms and cuda with pacman command:
sudo pacman -Rsn cuda nvidia-470xx-dkms

then try again to remove nvidia driver from your system

Thanks for the suggestion; I hadn’t used the -Rsn argument before. That worked, and I was able to uninstall those two plus video-nvidia-470xx.

However, on rebooting, it’s still getting stuck somewhere in the process. Now with Quiet mode off, I’ve seen it freeze at these different steps so far during three reboots:

Finished Load Kernel Module Loop
Finished Record System Boot/Shutdown in UTMP
Finished Create Volatile Files and Directories

I also can’t Ctrl + Alt + F2 anymore - it seems like it’s completely locking up now.

boot into manjaro live usb, make sure you are connected to internet, open terminal and chroot:
manjaro-chroot -a
rerun update:
pacman-mirrors -f 5 && pacman -Syyu
if there are errors post the output here, if there are no errors and you are up to date, post output from:
mhwd-kernel -li && mhwd -l -li
pacman -Qs nvidia
ls /etc/modprobe.d
find /etc/X11/ -name "*.conf"

I’m running into an issue with the first suggestion:
manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sdd1. Check your

I loaded up the Partition Manager, and it looks like sdd1 is the LiveUSB. So I’m not sure if it’s it’s throwing an error there but then moving on to do what you were hoping, or if it’s failing there.

Just in case, I tried the pacman-mirrors -f 5 && pacman -Syyu, and that seemed to complete without errors. mhwd-kernel -li && mhwd -l -li gave the following results. Is this specific to the LiveUSB? Asking because when I checked the kernel version yesterday, it only showed linux62-rt.

Currently running: 6.1.25-1-MANJARO (linux61)
The following kernels are installed in your system:
   * linux61
Warning: config '/var/lib/mhwd/db/pci/network_drivers/r8168/MHWDCONFIG' is invalid!
Warning: config '/var/lib/mhwd/db/pci/network_drivers/rt3562sta/MHWDCONFIG' is invalid!
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
> 0000:01:00.0 (0300:10de:13c2) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2023.03.23               false            PCI
    video-nvidia-470xx            2023.03.23               false            PCI
    video-nvidia-390xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

“pacman -Qs nvidia” gives:

local/lib32-libvdpau 1.5-1
    Nvidia VDPAU library
local/libvdpau 1.5-1
    Nvidia VDPAU library
local/mhwd-nvidia 530.41.03-4
    MHWD module-ids for nvidia 530.41.03
local/mhwd-nvidia-390xx 390.157-6
    MHWD module-ids for nvidia 390.157
local/mhwd-nvidia-470xx 470.182.03-2
    MHWD module-ids for nvidia 470.182.03
local/xf86-video-nouveau 1.0.17-2 (xorg-drivers)
    Open Source 3D acceleration driver for nVidia cards

The last two commands gave:


looks like those are output from the live usb…
what kernel(s) do you have installed in your system?
do you have encryption or btrfs?
post the whole output from:
manjaro-chroot -a

When I checked the kernel earlier (before using the LiveUSB, and when I could still Ctrl + Alt + F2), the only listed kernel was linux62-rt.

I have some kind of Luks setup for encryption - I do still get prompted for that password on a reboot, and it does accept it before continuing the boot process (and eventually getting stuck, currently).

When I try manjaro-chroot -a using this LiveUSB, this is the whole output I get:

[manjaro manjaro]# manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your
==> ERROR: No Linux partitions detected!

In the Partition Manager, though, I do see my Linux boot drive, and it does display the partitions on it.

manjaro-chroot -a doesnt work with btrfs and encrytpion…
post output from:


More info on my drives: nvme0n1 should be my drive with Linux installed. I also have an SSD with Windows, and two HDD with data but no OS.


PATH           PTTYPE PARTTYPE                             FSTYPE      PARTTYPENAME
/dev/loop0                                                 squashfs    
/dev/loop1                                                 squashfs    
/dev/loop2                                                 squashfs    
/dev/loop3                                                 squashfs    
/dev/sda       dos                                                     
/dev/sda1      dos    0x7                                  ntfs        HPFS/NTFS/exFAT
/dev/sdb       gpt                                                     
/dev/sdb1      gpt    de94bba4-06d1-4d40-a16a-bfd50179d6ac ntfs        Windows recovery environment
/dev/sdb2      gpt    c12a7328-f81f-11d2-ba4b-00a0c93ec93b vfat        EFI System
/dev/sdb3      gpt    e3c9e316-0b5c-4db8-817d-f92df00215ae             Microsoft reserved
/dev/sdb4      gpt    ebd0a0a2-b9e5-4433-87c0-68b6b72699c7 ntfs        Microsoft basic data
/dev/sdb5      gpt    de94bba4-06d1-4d40-a16a-bfd50179d6ac ntfs        Windows recovery environment
/dev/sdc       gpt                                                     
/dev/sdc1      gpt    e3c9e316-0b5c-4db8-817d-f92df00215ae             Microsoft reserved
/dev/sdc2      gpt    ebd0a0a2-b9e5-4433-87c0-68b6b72699c7 ntfs        Microsoft basic data
/dev/sdd       dos                                         iso9660     
/dev/sdd1      dos    0x0                                  iso9660     Empty
/dev/sdd2      dos    0xef                                 vfat        EFI (FAT-12/16/32)
/dev/nvme0n1   gpt                                                     
/dev/nvme0n1p1 gpt    c12a7328-f81f-11d2-ba4b-00a0c93ec93b vfat        EFI System
/dev/nvme0n1p2 gpt    0fc63daf-8483-4772-8e79-3d69d8477de4 crypto_LUKS Linux filesystem

and what is this? its also encrytped:

That’s labeled as root in the Partition Manager, and is ~932GB of the 1TB drive, so I assumed it was the main, encrypted portion of the drive containing the OS/filesystem, all my files, and free space for more stuff.

so try this:

sudo cryptsetup -v luksOpen /dev/nvme0n1p2 cryptDrive
sudo mount /dev/mapper/cryptDrive /mnt
sudo manjaro-chroot /mnt

just in case, post output from it

I’m getting an error on the first line. It asks for my password (which I assume is the luks one it always asks for on booting, not the password I use to log in to my normal Manjaro user account, but correct me if I’m wrong on that), so I enter that, and get the following:

device-mapper: reload ioctl on cryptDrive (254:0) failed: Invalid argument
Command failed with code -4 (wrong device or file specified).

I tried a couple times to make sure I wasn’t just typing the password incorrectly, but still got the same each time.

so try with nvme0n1:

sudo cryptsetup -v luksOpen /dev/nvme0n1 cryptDrive
sudo mount /dev/mapper/cryptDrive /mnt
sudo manjaro-chroot /mnt

and yes, you type the encryption password, and make sure num lock is on, if you are using numbers and capslock off

Hmm… that just gives:

Device /dev/nvme0n1 is not a valid LUKS device.
Command failed with code -1 (wrong or missing parameters).

The nvme0n1p2 is listed with a Type of luks in Partition Manager; I don’t see any others with that type listed.

so its the nvme0n1p2 … but it should work … reboot, and try again:

sudo cryptsetup -v luksOpen /dev/nvme0n1p2 cryptDrive
sudo mount /dev/mapper/cryptDrive /mnt
sudo manjaro-chroot /mnt

Okay, looks like the reboot (or something) helped there.

I ran all three commands without errors, and now after the third one, my prompt just looks like this:


ok, so you are chrooted, now run these:

I did get one warning in the running the first command:
warning: manjaro-hello: local (0.7.0-6) is newer than extra (0.7.0-5)

But it continued on and tried to update one package (inxi- The results of that:

(1/1) upgrading inxi                                               [####################################] 100%
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Refreshing PackageKit...
Error connecting: Could not connect: No such file or directory
error: command failed to execute correctly

Should I continue and post the output of the other commands, or not yet?

yes continue and post the output