Stuck lock screen


My problem is trivial yet annoying. I was switching themes just to get back to the original breath, yet the lock screen is still possessed by one of the previous themes; the initial login page is perfectly fine and looks as i would like to see the lock page. How do i force this transition?

System Settings > Workspace Behavior > Screen Locking > Appearance

Sadly that only changes the background and the splash, the things are different when i get to the point where i enter the password. The lock screen is quite different from what i have on my laptop with pristine installation and certainly comes from another theme, up to the point that the panel on top has a clock that never updates (which is most certainly not something from the official distribution).

System Settings > Start and Shutdown > Login / SDDM

sddm does not provide the lock screen; the lock screen comes from kscreenlocker. :stuck_out_tongue:

1 Like

There is no longer a a ‘theme’ configuration of the lock screen.

See for example my file;

$ cat ~/.config/kscreenlockerrc



I suppose you can try re-applying the ‘look-and-feel’ or ‘global’ theme.

Sadly i was in the login / sddm section, kscreenlockerrc looks pretty much the same, yet i certainly have a different login form and screen. Theme change also doesn’t help.

I hate noisy blurry abhorrent shots as anyone else, but i guess this calls for an illustration. Bottom is a pristine installation that i want, top is what i get. I guess it’s worth noticing that the installation is pretty old, ~2020 or something (obviously regularly updated, but this may be a backwards compatibility thing)

Did you try this?

On that note … what theme are you using?
(the old breath was replaced by breath2, and later renamed to breath-classic, with breath2 becoming breath … maybe related?)

Did you try this?

Yes, more than once

On that note … what theme are you using?
(the old breath was replaced by breath2 , and later renamed to breath-classic , with breath2 becoming breath … maybe related?)

Breath. I’m not sure which one it is in terms of id, but in my current setup i have Breath, Breath Dark, Breath Light; i’ve tried switching to all of them with no effect.

Which Plasma version are you running ? Latest 5.27.10 ?

Did you test with a new user account ?

pacman -Qs breath

The one at the bottom is kscreenlocker. The one at the top is lightdm, the display manager that comes as the default in Xfce.

Thank you, at least now i know what’s going on. Do you have any suggestions on how i can revert it?

Uninstall lightdm and install sddm instead? :man_shrugging:

sddm is installed, lightdm isn’t

According to OP its not the login, but the lockscreen thats the ‘issue’.

So if your idea about lightdm (or similar) is true …
they may have enabled light-locker over kscreenlocker.

So … I might ask

pacman -Qs lock
1 Like
$ pacman -Qs lock

local/cryptsetup 2.6.1-3.4
    Userspace setup tool for transparent encryption of block devices using dm-crypt
local/kbd 2.6.4-1
    Keytable files and keyboard utilities
local/kscreenlocker 5.27.10-1 (plasma)
    Library and components for secure lock screen architecture
local/libadwaita 1:1.4.2-1
    Building blocks for modern adaptive GNOME applications
local/libblockdev 3.0.4-1
    A library for manipulating block devices
local/libdispatch 5.5.0-1
    Comprehensive support for concurrent code execution on multicore hardware
local/numlockx 1.2-5
    Turns on the numlock key in X11.
local/onetbb 2021.10.0-1
    High level abstract threading library (oneAPI Threading Building Blocks)
local/python-filelock 3.13.1-1
    A platform independent file lock
local/python-zc.lockfile 3.0.post1-2
    Zope testing frameworks
local/qemu-block-curl 8.1.3-1
    QEMU curl block driver
local/qemu-block-dmg 8.1.3-1
    QEMU DMG block driver
local/qemu-block-nfs 8.1.3-1
    QEMU NFS block driver
local/qemu-block-ssh 8.1.3-1
    QEMU SSH block driver
local/ruby-io-nonblock 0.1.0-3
    Enables non-blocking mode with IO class
local/ruby-io-wait 0.2.3-4
    Waits until IO is readable or writable without blocking
$ pacman -Qs locker

local/kscreenlocker 5.27.10-1 (plasma)
    Library and components for secure lock screen architecture
$ pacman -Qs breath 

local/breath2-wallpaper 1.0.13-1
    breath2 wallpaper
local/gtk-theme-breath 5.9.0-1
    Breath widget theme for GTK 2 and 3
local/plasma5-themes-breath 23.0.0-1
    Breath theme for KDE Plasma 5
local/plasma5-themes-breath-migration 23.0.0-1
    Breath theme migration routine for kconf_update
local/sddm-breath-theme 23.0.0-1
    Breath theme for SDDM

So … maybe that light* assumption is incorrect.

When you say you switched themes … how/what did you change?

Normally it seems to me that kscreenlocker changes with the Desktop Theme (“Plasma Style”)… but if that does not work for you, have you tried applying a look-and-feel (“Global”) theme ?

When you say you switched themes … how/what did you change?

That was an ancient change, maybe a year ago (i just got fed up by this), but pretty sure it was applying global theme. Tried switching SDDM login screen as well, but can’t see any changes (will try to reboot later, but i doubt it will help)

Over a year ago?

Then it supposedly happening was never relevant for us here and should have been the first step.

Well … please then … select a different Desktop Theme (plasma style), apply, then reselect breath and apply.

Thats what will change your lock screen.

We have already gone over kscreenlocker is not sddm :wink: