Stuck in Package hell

I am unable to update any of my packages anymore. Every upgrade fails with the message: “- unable to satisfy dependency ‘nvidia-utils-beta>=535.54.03’ required by nvidia-settings-beta”

So, I tried to install nvidia-utils-beta, which fails with:
“- removing nvidia-utils-beta-nvlax breaks dependency ‘nvidia-utils=530.41.03’ required by lib32-nvidia-utils”

So I tried to install lib32-nvidia-utils-beta.

This also fails as linux61-nvidia requires a specific version of nvidia-utils=530.41.03.

How can resolve this? Thanks.

That’s what you get when you enter the AUR.

Is there a reason you installed the beta versions? Remove everything you installed and install the versions from the repos.

pamac remove --cascade nvidia-utils-beta
sudo mhwd -a pci nonfree 0300

Thank you! Part 1 solved, was able to remove and reinstall stock nvidia drivers, and upgrade all official repo packages, which is already a BIG win!
Still not out of the woods though as I am still unable to update any AUR packages.

cp: cannot create regular file '/var/tmp/pamac/dbs/sync/pamac_aur.db': Permission denied
Error: Failed to prepare transaction: target not found: ckbcomp

Weird thing is that the pamac-aur.db file is located at /var/tmp/pamac.
I did a full remove of /var/tmp/pamac and pamac update, but same result.

Not even sure if that is the reason for target not found error, which I get on all AUR packages I want to upgrade.

I did:

sudo pacman-mirrors -f && sudo pacman -Syyu
pamac upgrade -a

but this did also not help.
What do you think is causing the problem, and what can I do to resolve it?

ups, the option pacman-mirrors -f needs a number to specify the accepted mirrors.
update mirror list and select the 5 fastest mirrors

sudo pacman-mirrors -f5

an alternative is to select regional mirrors. this can be more effective if
fast mirrors and a good infrastructure are provided in your country.

replace Germany with your country

sudo pacman-mirrors -c Germany

you’ll need to try for yourself which option is the best result to use in your country

note: you can only use one of the options. use “-f5” or “-c country”

are you using stable or unstable ? may you post the output of

pacman-mirrors -G

I am on stable. I tried different versions including the ones you mentioned. Makes no difference to my problem :frowning: .

may you try the following

sudo pacman -Scc
sudo pacman -Syyu
pamac update --force-refresh --aur

and report

Thank you for the suggestion.
It cleared the cache, but in the end results in the same thing

indeed there is a mess with the update-process of manjaro actually. seems that we’ll have to wait until the manjaro-team fix it. as you can see in other related threads they are still working on it.

Ok, thanks, I will be patient and see if it resolves itself in a couple of weeks.

It will. In the meantime, you have to refrain from using pamac or the GUI and stick to pacman and/or other trusted additional AUR helpers like yay.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.