Stuck at blinking cursor at boot after update

Hi folks,

first time ever trying out Manjaro.
In the weekend I’ve got the GNOME edition up and running on my machine and I was loving it. Alas, yesterday I’ve updated the system. At first all seemed to work fine; I’m not 100% sure now but I think I’ve even rebooted once with no issues. This morning though I’ve booted up my machine and after a few seconds I’ve got stuck with a black screen and a blinking cursor. No error messsages whatsoever.

I can still login in tty2 or tty3 so my Manjaro is there.
I’ve searched on the internet and so far I’m leaning towards 2 different potential issues:

  • I have to manually update grub.
  • I use Nvidia proprietary drivers and they got broken (so no GUI).

For grub, I did reinstall it from tty2 but I have still the same issue. For the records: I’m dual-booting with Windows 10 and I’ve created a second EFI partition when I installed Manjaro to not mess up the with the other one.

It was basically a fresh install so I’ll probably just reinstall it but I feel like I need to understand what’s going on here.

Any suggestions?

Thank you!

Hello and welcome,

Please try to follow this instructions and the linked topics:

Let us know how it goes or if you require more assistance.


Thank you so much for your reply and your welcome :slight_smile:

So I followed the instructions on the link you gave me, refreshed the mirrors and check for updates but the system was all up to date.

I then started X and I’ve got an error. In the Xorg log it says:

NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the system’s kernel log for additional error messages.

I couldn’t find the system’s kernel log into /var/log, though so I couldn’t check any further. Where is it?

Bare in mind that I had to install the CUDA libraries for Blender as well.

Where do I go from here?

Thanks again!

Could you post the output of inxi -Gxx and mhwd -li?
Please note that you can still upload logs/etc relatively easily with no-install pastebins.
For example like this:
<command> | curl -F 'f:1=<-'

Here you go:

Graphics:  Device-1: NVIDIA TU102 [GeForce RTX 2080 Ti Rev. A] vendor: ASUSTeK driver: N/A bus ID: 0a:00.0 chip ID: 10de:1e07 
       Display: server: 1.20.8 driver: N/A note: display driver n/a - try sudo/root FAILED: nvidia tty: 160x45 
       Message: Advanced graphics data unavailable in console. Try -G --display 

              NAME               VERSION          FREEDRIVER           TYPE

video-nvidia-440xx            2019.10.25               false            PCI

e[1me[31mWarning: e[mNo installed USB configs!

Hmmm we could try a forced reinstall of the driver first.
mhwd -f -i pci video-nvidia-440xx
after that just to make sure let’s update grub again.

If that does not work let’s take a look at the kernels error messages with
dmesg -l emerg,alert,crit,err,warn

Unfortunately it gives an error:

Error: config ‘video-nvidia-440xx’ conflicts with config(s): video-nvidia-440xx

Am I just unlucky or this kind of problems happen everytime there is a big update in Manjaro? Asking for a friend…

Here’s the output of dmesg for errors:

[    0.620763] efi: memattr: Entry attributes invalid: RO and XP bits both cleared
[    0.316947] do_IRQ: 1.55 No irq handler for vector
[    0.732769]   #2
[    0.316947] do_IRQ: 2.55 No irq handler for vector
[    0.734893]   #3
[    0.316947] do_IRQ: 3.55 No irq handler for vector
[    0.736091]   #4
[    0.316947] do_IRQ: 4.55 No irq handler for vector
[    0.739428]   #5
[    0.316947] do_IRQ: 5.55 No irq handler for vector
[    0.741585]   #6
[    0.316947] do_IRQ: 6.55 No irq handler for vector
[    0.742765]   #7
[    0.316947] do_IRQ: 7.55 No irq handler for vector
[    0.746093]   #8
[    0.316947] do_IRQ: 8.55 No irq handler for vector
[    0.748254]   #9
[    0.316947] do_IRQ: 9.55 No irq handler for vector
[    0.749425]  #10
[    0.316947] do_IRQ: 10.55 No irq handler for vector
[    0.752761]  #11 #12 #13 #14 #15 #16 #17 #18 #19 #20 #21 #22 #23 #24 #25 #26 #27 #28 #29 #30 #31
[    0.963694]  PPR X2APIC NX GT IA GA PC GA_vAPIC
[    0.991570] nvme nvme0: missing or invalid SUBNQN field.
[    0.996648] nvme nvme1: missing or invalid SUBNQN field.
[    1.390618] ACPI BIOS Error (bug): AE_AML_PACKAGE_LIMIT, Index (0x000000007) is beyond end of object (length 0x6) (20200326/exoparg2-393)
[    1.390623] ACPI Error: Aborting method \_SB.PCI0.BXBR.BYUP.BYD8.XHC1.RHUB.PRT6._PLD due to previous error (AE_AML_PACKAGE_LIMIT) (20200326/psparse-529)
[    2.026847] sp5100-tco sp5100-tco: Watchdog hardware is disabled
[    2.235432] kvm: disabled by bios
[    2.353801] usb 1-5.3: config 1 has an invalid interface number: 2 but max is 1
[    2.353804] usb 1-5.3: config 1 has no interface number 1
[    2.363881] kvm: disabled by bios
[    2.534515] kvm: disabled by bios
[    2.674868] kvm: disabled by bios
[    2.848684] kvm: disabled by bios
[    3.062138] kvm: disabled by bios
[    3.260840] kvm: disabled by bios
[    3.435660] kvm: disabled by bios
[    3.608628] kvm: disabled by bios
[    3.762621] kvm: disabled by bios
[    8.106535] kauditd_printk_skb: 43 callbacks suppressed
[   32.610421] kauditd_printk_skb: 4 callbacks suppressed

Hmmm going on a hunch here, but could you post the output of mhwd-kernel -li?
I’m currently not exactly sure either what is going wrong.

Here you go:

e[32mCurrently running:e[0m 5.7.14-1-MANJARO (linux57)
The following kernels are installed in your system:
  * linux57

Well since the forced reinstall refused to work, you could still try to remove the old driver install and then reinstall.
sudo mhwd -r pci video-nvidia-440xx && sync && sudo mhwd -i pci video-nvidia-440xx.
You could also try and test the new 5.8 kernel. You can install it with sudo mhwd-kernel -i linux58 .

It looks like the issue is somehow related to CUDA, when I try to uninstall the nvidia drivers I get this error message:

error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-440xx-utils breaks dependency 'nvidia-utils' required by cuda
Error: pacman failed!

So as a summary:
The drivers need to be reinstalled because the installation seems to have gotten broken during the update.
Normally that can easily be done with this command:
sudo mhwd -r pci video-nvidia-440xx && sync && sudo mhwd -i pci video-nvidia-440xx .
In this case though the driver reinstall was blocked, since CUDA depended on it. As such the CUDA package needs to be temporarily removed first, then the drivers reinstalled and then can be reinstalled.

It worked.

I’ve uninstalled the cuda package and then removed and reinstalled the nvidia drivers and now I’m typing from Manjaro.
Now I need to figure out what’s up with the CUDA libraries though.

Thank you so much for all your help!

You needed to uninstall the cuda libraries to reinstall the driver… the cuda libraries were not the problem, only a slight setback in reinstalling the drivers.
Also it is generally frowned upon to give oneself solved topics. Generally the post that had the answer first is supposed to be selected.

I honestly think that my last post marked as solution and therefore appearing under my first post would be much more useful to a random reader than your latest post taken out of context. Also I’ve already thanked you and it’s not a mystery that you’ve helped me with this issue. But fair enough, have your digital pat on the shoulder here…

Where I’m from being passive aggressive is frowned upon.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.