Stuck at Asus Boot logo

So before I get into my issue, I just want to make clear yes I did look up my issue within the forum before making this post but I do not believe their issue lines up with mine and I didn’t want to attempt to try their solutions if it ended up making my situation worse, because I use Linux fairly casually, but other than that let me get into my issue.

I was trying to install some tools for C/C++ (mostly C cause that’s what I’m going to be learning at my university course) just so I could execute some code from terminal and be able to follow along with this book that teaches C. The install went fine but a couple minutes afterward I tried opening a new tab in firefox and it wouldn’t load. I tried it a couple times and decided to restart to see if that would fix it, then I tried booting into Linux and I’m just stuck at my OEM boot screen and it won’t go into the login screen. If it helps I ran sudo pacman -Sy base-devel and went with all of the default selections (according to this video Super Easy C / C++ Tools Install on Linux - Create and Compile Your First Program with GCC / G++. by SavyNik) and I run the latest Manjaro. I thank everyone in the future who will offer their help with my issue and hope this can be solved without too much issue.

so you are stuck at asus logo? there is no black screen, no message?

yeah it’s just the asus logo, no spinning wheel, no message, just a black screen with asus logo in the center

can you use your installation-medium and try to boot this to a live iso ? also can you check if there are bios settings changed that might prevent booting ? both is just to make sure that there is no bios-fault and you can boot to a live-system you know that works ?

Could you list some BIOS settings that could affect it, cause as far as I know with manjaro it’s secure boot and I have that disabled. Also I’m going to try booting off the USB right now and I’ll give an update

so I just booted onto a live-usb with no issue, so that shows it not bios and it can get into a live system fine

so chroot:
sudo manjaro-chroot -a
provide logs:
journalctl -b-1 -p4 --no-pager
also output from this:
test -d /sys/firmware/efi && echo efi || echo bios
mhwd-kernel -li

1 Like

I’m assuming I just run this in the live-usb or the GRUB commandline?

yes in the live usb, connect to internet, open terminal and run the commands

gotcha, give me a minute

Dude thesee outputs be chunky

thats a lot of logs for only getting stuck at asus logo … post also output from:
cat /var/log/pacman.log | grep install | tail -30
inxi -G
mhwd -l && mhwd -li

I’m just as surprised as you man, but give me a sec once again

requested outputs

there is nothing you installed today, there is from yesterday when you installed bleachbit …
but this is probably the issue:

mhwd: /usr/lib/ version `GLIBC_2.36' not found (required by /usr/lib/

rerun update, probably you get the same error:
pacman-mirrors --fasttrack 5 && pacman -Syyu

1 Like

So what should I do once the command you’ve given me finishes run, should I try running my native Linux or what?

wait a moment, so the command worked without the glibc error? and it is actually running an update?

Yes it just finished

and no errors? was it succesfull?

Here I’ll give you the outputs to look at update output