Struggle to recover the functionality from before this summer's updates - here: Thunderbird & Birdtray

I’ve been struggling to re-build my Manjaro system on a new computer for the past ½ year.
While a few minor enhancements came with the updates, they’ve broken a lot of more important functionality.
I have a separate installation on my notebook computer, which still works as desired.
But it seems impossible to clone that one onto the new machine, so I keep trying to get it into a new install.
After several months during which unified folders of Thunderbird had been broken (since update from version 102 to 115), it has “repaired” itself (by a silent update?) about a week ago: the (~15th) de- and re-install now shows the accounts and folders of the copied profile correctly.

But the system refuses to let Birdtray work:
Bildschirmfoto vom 2023-11-15 09-37-07
(the “protocol” is nothing more than the 1-liner in the error message
~ “the panel cannot be controlled by this Add-on”)
I vaguely remember to have seen a similar message some years ago and that it had been easy to fix but don’t remember how.

Differences between the new system / the “reference” on the notebook:
Linux 66 / 65
Gnome 45 / 44
Wayland / X-Windows

There is no such thing as silent updates.

Especially for Mozilla apps - the changes in configuration profiles - can cause various issues when you try to move settings from one system to another.

birdtray is an unsupported script from AUR - will require occasional rebuilding - most notably when thunderbird is updated.

There is fundamental differences between wayland and xorg - and Gnome itself is well known to break extensions when upgrading to the next release.

This shows your system is incompatible with the addon - birdtray - and you will need to find out why - maybe even drop it completely.

That’s why I put that question mark - I don’t understand why it suddenly works after so many same unsuccessful tries - without additional manual changes or interventions (except for 3 re-boots - which I had tried earlier as well).

Until now it had been sufficient to adjust its basic .json-file.
And I don’t expect “official” support - this is rather an appeal for help to the community.
I know that Gnome-Shell-Extensions are broken by updates - currently 4, for which I hope for updates.
But Birdtray is not a Gnome-Shell-Extension, is it?

That’s exactly the purpose of this topic.

And you have checked the AUR page

and upstream

Have you tried logging into Gnome using Xorg vs Wayland (If I recall Wayland is default)

Sure, but … got lost in there, didn’t understand enough of it.

Sure - but it might be time to try that again … (and yes Wayland is the new default - X now breaks other details) … will take 15 minutes to store open work, etc.
(Wondering if installing “trayer” could fix it ←note to myself, because I’ll loose that open window on re-boot.)

Now on Xorg - doesn’t work either, but … delivers more detailed information:

(Reinstalling made no difference.)
Which of the suggested “platform plugins” might be most suitable?
None of them appears in Pamac. And those with similar names refer to components I don’t use anyway.

And - OT - cordial thanks to you, “linux-aarhus”, for bothering to help a Manjaro re-beginner so readily!

Thunderbird 115 (Supernova) was a big rewrite which had numerous issues on release including unified folders. Most of these issues were fixed in later releases - Thunderbird/Support/TB115.0SupportIssues - MozillaWiki. Or instead of waiting you could have gone to Thunderbird Help type in “unified folders” and find posts like this one which describe how to fix it manually.

Birdtray doesn’t have proper Wayland support. Typing “birdtray wayland” into a search engine finds articles like this one;

What worked in my tests (on Ubuntu with GNOME running on Wayland, Kubuntu with Wayland and Manjaro KDE with Wayland) was to start Birdtray using env XDG_SESSION_TYPE=x11 birdtray, and in the Birdtray settings have the Thunderbird command line option (on the Advanced tab) set to /usr/bin/env GDK_BACKEND=x11 /usr/bin/thunderbird.

1 Like

… had really lived up to its name - destroyed its “progenitor” like a Supernova.
As stated directly above, Thunderbird has been revived after some months - current version is 115.4.2

Since my system currently uses Xorg - which doesn’t restore Birdtray’s functionality but gives a more detailed error message, I doubt that looking for a solution of Wayland-specific issues would help.
And - I don’t know how to use “env XDG_SESSION_TYPE=x11 birdtray”. Would that have to be written into the app starter for Birdtray?

Which says it’s failing while trying to open a Wayland display (wl_display) which it shouldn’t be doing on Xorg… :man_shrugging:

If that’s where birdtray is started from yes. Test it from the command line first.

That startled and confused me as well …

Putting the “env … birdtray” line into a terminal made me understand what that really tries to do:
exactly same result as “birdtray” alone.

I’m sorry then I can’t help any further. I don’t use either GNOME or Wayland myself, maybe someone who does will know more.

I don’t use thunderbird or mailbird - but out courtesy I did a test using qemu and virtmanager.

  1. Installed the current Gnome ISO
  2. Installed Thunderbird
  3. Setup my mail address
  4. Used pamac to build mailbird birdtray
  5. Started mailbird birdtray

It looks like it works as one would expect.

I am thinking, that your attempts to move a profile/mailbox to have the same setup on a new system, is causing your frustrations.

From a clean install it appears as it is working - bear in mind that I am no use of the said apps - I am just validating if the apps are working - and I am happy to say - they do.

This may not be good news to you - but it is the best I can do.

 $ pacman-mirrors -G

 $ inxi -Sxxx
  Host: nix Kernel: 6.5.11-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 13.2.1 clocksource: kvm-clock Desktop: GNOME v: 45.1 tk: GTK v: 3.24.38
    wm: gnome-shell dm: GDM v: 45.0.1 Distro: Manjaro Linux base: Arch Linux

Oh! Never read about mailbird - that might be the solution after the failure of Birdtray.
Will try it after de-installing Birdtray, which brought a huge pile of Qt- and related components as dependencies.

edit: my pamac doesn’t find a “mailbird” package. :frowning:
Well, it’s an MS-Windows App and the only Linux alternatives I haven’t tried so far seem to be Vivaldi Mail and Betterbird. Will have a look at these.

Or - wait a minute - how did you persuade pamac to build mailbird?

Mailbird is not found in AUR. Not sure if he mistyped or not.
As far as I can tell, it’s not available for Linux.

I apologize - I mistyped - I have no idea where that bird came from

Relating to the comments on the environment variables - I have made no changes to the defaults - of course I have no long time experience - just running the installers and launching the tray app.

The launchers Exec line is no more than


Never mind - the ornithology of mail clients has become increasingly confusing.
And you made me find Betterbird / Vivaldi as potential replacements for Thunderbird / Mozilla.
… which look interesting but leave concerns about their life expectancy - after 25+ years with the Mozilla apps.

A possible difference between your test installation and mine might come from its starting point: I have started it from a “minimal” iso image hoping to avoid some of the bloat that comes with it. Wouldn’t be the first time that it just lacks a small helper function that had been “forgotten” in the dependencies. (iirc, something like that was the reason why I have seen a similar error message some years ago - but had no difficulty to find the “missing ink” back then)

Vivaldi is slowly becoming my browser of choice - for the forum - due the the ease of translating my english comments into german for posting alongside when commenting in Deutsch

And yes - it has a quit neat mail client :slight_smile:

I haven’t found much not to like about Vivaldi; admittedly, I’m a die-hard, when it comes to Thunderbird for email.

I particularly enjoy the multiple pane arrangements of concurrent tabs, which I recall Firefox attempting, with limited success.

Took some time - hard time - to clarify the(se) issue(s).
Had forgotten the passphrase for my parallel test installation on a separate partition.
Re-installing without formatting seemed restore the access to that (not yet encrypted) installation, but … corrupted the (somewhat productive) main installation on access to its home folder. Restoring that per Timeshift made the test installation again unusable.
So I had to re-make the test installation from scratch: 1 full day and still much left to be amended.
But I have, again, learned a lot during this exhausting proceedure.

Answers to above open questions:
Installation of current Thunderbird and using the copied profile of the reference installation works absolutely smoothly.
Birdtray works on the current “standard” installation (the bloated one), but not on “minimal”. (Do not (yet?) know which component of the bloat is needed for Birdtray. Perhaps I’d have to invest another week to re-create the main installation from the “standard” rather than minimal ISO.) The old configuration (.json file) does not work but is now more easily re-configured manually.
Some really hard hours: Firefox freezes in a minimal window when trying to use the profile of the reference (same FF version) - the new install needs the extensions folder in the parent of (rather than inside) the profile folders.

New and “re-arising” questions about Timeshift, cronjob, setting up a virtual machine, …

Meanwhile, i.e. since Wednesday to Thursday night, it has become clear that the only missing part was the “AppIndicator and KStatusNotifierItem Support”-extension. And I think that it had been exactly the one “I vaguely remembered” - but had forgotten its name and its paramount significance for a usable Gnome.
Back then it had been easy to find in the “system-extensions” from which it has meanwhile been removed for inexplicable reasons.
This also solved the most important of the next (planned) topics: Dropbox and Telegram which had worked rudimentarily, but didn’t allow access to their settings, i.e. were not really usable.