Stream audio from Android phone to pc speakers is broken

Hello, hope you’re doing well folks, it’s my first time posting.

What happened is that a recent update broke a thing that I used daily that is connecting my phone to my computer. It allows me to stream the audio, so that I can hear notifications, watch videos, etc on my phone without taking my headphones off.

Now, my phone gets connected, it shows up as a microphone, as before. and I can see there is a signal arriving, and my phone mutes. It just doesn’t redirect to my speakers.

I tried to use qpwgraph to do it manually, but I’m new to configuring pipewire and didn’t get how to use it. I only get 2 MIDI Through devices that are not physical, while my real card, mic, and phone don’t show up.

Any ideas? Is this a bug? Maybe it was actually a bug earlier that streamed my audio? Maybe I’m xkcd 1172 IRL.

I haven’t made the switch to Pipewire yet, but there seems to be only way I could get the line-in input to work (or streaming as you call it). With Pulseaudio all I could do was make a loopback module, and it was unbearable.

Your audio chipset just needs a toogle to listen or unmute, and you can adjust the volume/gain.

I haven’t tried this with Pipewire, but this might be worth a go…

Find your sound card number with: alsactl info

With the proper number from above use the command: alsamixer --card=1

You can then use the arrow keys.

I have tried leaving everything at full volume, but it did not work, It did show up as an input, and I could change its volume. I assume Manjaro uses pipewire by default doesn’t it?

Never mind, the problem solved itself. Now it works as before for some reason. Maybe Manjaro sent an update or it was, indeed, a bug. Thanks for the help anyways.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.