Strawberry won't launch, missing libraries

I tried to install Strawberry Music Player via pacman (cmd shown below)

sudo pacman -S strawberry

After installation I tried to launch from the application launcher but it wouldn’t launch so I tried from the console and it returned the following:

strawberry: error while loading shared libraries: cannot open shared object

I tried installing using the GUI package manager as well but to the same result. So from what I understand, my system’s missing and I haven’t been able to find a walk through on how to install this manually. I have upgraded all there is to upgrade and still haven’t been able to install this library.
Any help would be appreciated!

If it’s any help I also tried Clementine and I got the same error.

strawberry is a package that we import directly from Arch, so your best bet is to contact the Arch package maintainer.


sudo pacman -S gstreamer

Still doesn’t work 3:

It gives me the same error as before.

Try now:

Yeah, I tried the edit before too. Still doesn’t work.

Try this… :arrow_down:

cd /usr/lib
sudo ln -s

It’s a long shot, but if it doesn’t work, then you’ll have to remove the symlink again… :arrow_down:

sudo rm -f /usr/lib/
sudo pacman -S gst-plugins-base-libs

The file is not in that package. In fact, I believe the packager may have made a typo when he built the app and linked it against a non-existing library.

This worked!
I was looking thru usr/lib and all the file names looked incorrect for that library, doing

sudo pacman -S gst-plugins-base-libs

seemed to fix it! Thank you both <3

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.