Strawberry qt5 fails to open

I use the repo chaotic aur, this repo has this package on it and in my stable manjaro is not giving me any error in the launch time but in testing it gives me the error:
strawberry: /usr/lib/ version `GLIBCXX_3.4.30’ not found (required by strawberry)

I feels like it has to be a problem in libs of compilation time, but it feels weird that testing branchs for me has this problem with a repo from arch and stable manjaro branch not when arch is more bleeding edge on libs… so I think it has to be another problem that maybe it’s in another packages from community.

any idea?

Don’t use third party repos. :person_shrugging:

yeah, i know the general answer to this. But to be honest I expect that this will affect another packages since it’s dffernt than I used to .
In general a third party repo fails in stable and testing, both. if testing gets updated it won’t fail and after stable not the reverse. Do you understand?
so it feels weird… may be i’m searching a answer to the question since I know the fix is to not to use it and use aur instead.

Not sure how to solve this, searching for the error leads to a thread where the solution was to downgrade the application.
pamac says:
/usr/lib/ is owned by gcc-libs

Stable 11.2.0-4
Testing 12.1.0-2
Unstable 12.1.0-2

when I go home to my stable manjaro pc I will reinstall this strawberry version to see if it launchs well.

it’s weird to see strawberry failing with libs that are the same from arch so I think it has to be something wrong more, don’t you think?
Idk if it fails on arch but I don’t think so

It needs to be rebuilt. Seeing how the repo maintainer neglected to do that, rebuild it from the AUR.

okey, i’m stupid. I have compiled on my own the strawberry qt5 package from aur on manjaro stable… so… it’s why the package give no errors on my another PC. I have installed from repo and the same error is here.

But for me it gives me another question, why having manjaro testing the same libs version than arch linux gives me errors launching strawberry?
it has no sense… any idea?

edit:more debug done, my selected mirros was outdated so my gcc libs were outdated too… it’s why the error here people.

sorry -.-

1 Like

Thanks for letting this know, others with the same issue will benefit from this knowledge and you solved it.

I’ll mark the thread solved :+1:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.