Strange sudo password issue

Hey guys, I have a strange sudo password issue I can’t seem to find a solution to (or the cause of) anywhere online. Someone did post the same problem on a forum somewhere, and found a band-aid fix that worked for a couple weeks for them, and for me.

The problem is when I go to update (yay -Syu), type the password, hit enter, and get nothing. The band-aid fix was to su, delete the password, go back to user, and create the password again, which worked for about 2 weeks. Any idea what would even cause this?

just a possibility:
maybe you have some startup script, which fails and
lock your login, so you would have to get rid of that eventual startup script.

in such a case,
faillock --reset would give you instant access,
but it is just a temporary solution

1 Like

Which password are you referring to in this case :thinking:
The root-account should not have a password and should be disabled for logins, when you use sudo it actually asks for your user-account’s password.
Because the first user-account is part of the wheel group which is allowed to use sudo
See: sudo -l

That is not sudo :wink:
(Unless you meant sudo yay -Syu)

1 Like

When I type yay -Syu into the terminal, it asks for the users password. I type the password, hit enter, and the updates run. What’s happening here is when I type yay -Syu into the terminal, it asks for the users password, I type the password (correctly), hit enter, it says “wrong password,” and asks me to type it again. I do this three times, and it kicks me out for too many wrong password attempts.

The band-aid solution was this:
su (root password)
passwd -d [username]
[enter new password, same as old password]
yay -Syu
[enter password]

And the update commences.

This is happening on my parents computer, so maybe they entered the password with capslock on three times, and it locked them out or something? I just don’t know what would cause this to happen, and why resetting the password fixes it.

Maybe, but this is on my parents laptop. I installed Manjaro, Google Chrome, a couple solitare games, and sent it to them, so there shouldn’t be any startup scripts loading. Would it lock them out if the password was typed wrong too many times? Deleting and resetting the user password was the temporary fix I used.

yes that’s why

Read the manpage of that command man faillock :wink:
It will give you info on how to check if they indeed did mistype…

Create another account just for you that is part of the wheel group so you can always login in those cases to check and fix stuff via the console.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.