Strange screen flickering issue

I’ve recently started experiencing a strange issue with my laptop (Dell XPS 9570) where the screen seems to flicker back between its current state and the state it was at a few frames ago. It’s really distracting when I’m typing because the text will seem to disappear, only to reappear if I type some more.
I don’t recall anything in particular I might have changed to cause this issue, and it only seems to be a problem when I’m typing. It’s especially bad when I’m typing into kitty or Slack, occurs much less frequently in Firefox, and is nonexistent in Telegram. I don’t observe this artifact when watching videos or any other kind of moving content, only when I’m typing.

Here’s my inxi output:

System:    Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: GNOME 3.38.1 tk: GTK 3.24.23 
           wm: gnome-shell dm: GDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: XPS 15 9570 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 02MJVY v: A00 serial: <filter> UEFI: Dell v: 1.17.1 date: 07/09/2020 
Battery:   ID-1: BAT0 charge: 57.9 Wh condition: 64.3/97.0 Wh (66%) volts: 12.6/11.4 model: LGC-LGC8.33 DELL 5XJ28 
           serial: <filter> status: Charging 
CPU:       Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52815 
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nvidia v: 455.45.01 bus ID: 01:00.0 chip ID: 10de:1c8c 
           Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-12:4 chip ID: 0c45:671d 
           Display: x11 server: 1.20.10 compositor: gnome-shell driver: modesetting,nvidia unloaded: intel,nouveau 
           alternate: fbdev,nv,vesa resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.2.3 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Device-2: C-Media Q9-1 type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-5.3:10 chip ID: 0d8c:0135 
           Device-3: Razer USA Gaming Webcam [Kiyo] type: USB driver: snd-usb-audio,uvcvideo bus ID: 1-2:8 chip ID: 1532:0e03 
           Sound Server: ALSA v: k5.9.11-3-MANJARO 
Network:   Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: 3000 bus ID: 3b:00.0 chip ID: 8086:2526 
           IF: wlp59s0 state: up mac: <filter> 
           Device-2: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb bus ID: 1-4:2 chip ID: 8087:0025 
           IF-ID-1: vpn0 state: up speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 476.94 GiB used: 266.12 GiB (55.8%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: KXG50ZNV512G NVMe 512GB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> 
Partition: ID-1: / size: 210.47 GiB used: 69.56 GiB (33.0%) fs: ext4 dev: /dev/dm-0 
Swap:      ID-1: swap-1 type: partition size: 7.70 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p6 
Sensors:   System Temperatures: cpu: 66.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2490 fan-2: 2488 
Info:      Processes: 383 Uptime: 9h 22m Memory: 15.26 GiB used: 4.67 GiB (30.6%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           clang: 11.0.0 Packages: pacman: 1522 Shell: Zsh v: 5.8 running in: kitty inxi: 3.1.08 

Did you checkout: NVIDIA/Troubleshooting - ArchWiki (Section: Avoid screen tearing)?

Strangely, the issue seems to have subsided (again without me doing anything; I didn’t even upgrade any packages), but if it comes back I’ll try that.

Not sure if this is the same issue but just posting in case.

  1. I updated one of my Manjro Plasma installs today. I noticed that the Shutdown menu has changed so I had to shutdown by searching for ‘Shutdown’ as the new icons did not appear until after reboot.

  2. When I rebooted screen flickered badly, most noticeably around the new Manjaro menu and browser hyper links.

  3. I searched for solution, tried changing Compositor settings but none of those changes helped even after reboot.

  4. Started changing settings randomly and discovered that when I changed the Manjaro display refresh rate from 60hz to 50Hz flickering stopped.
    I then changed it back to 60Hz and flickering did not come back.

Seems like there was some inconsistency between Manjaro and refresh rate setting of display which once changed and then back again fixed issue

1 Like

I’m brand new to Manjaro and basically linux everything was working great until I did an update and was having the exact same issue you were and what you said also fixed mine so thanks for sharing.

Also new here, but I had the exact same problem after this update. Reducing refresh rate to 50Hz and then increasing to 60Hz solved it for me too. Thanks!