Strange pictures when working with web browsers


I have been a very happy Manjaro user for about two years now. While mostly a joy, I noticed that when I work with websites like social media sites where I upload photos, they don’t seem to present themselves properly.

I have attached a screenshot from a case in which I would try to upload a profile picture to Twitter. The end result is a strange jumble of colours. It didn’t used to bother me, but the same problem happened with a special type of “I-am-not-a-robot” test involving moving a slider in a particular place in a picture, only to have the picture in question be a mess as well.

The computer I use is a Dell Latitude E7440, which possesses an i5-4310U processor and (more importantly) Haswell-ULT integrated graphics. I also use Firefox for all my browsing.

Thank you for reading my message!

What extensions are installed? Have you tried with all extensions disabled?

1 Like

Right now I have Bitwarden, Ublock Origins, ClearURLS, Decentraleyes, Multi-Account containers and WebRTC is disabled.

I have tried without any extensions, but the problem seems to remain.

Thanks for taking an interesting into my problem!

Have you tried with a clean profile and no extensions? Does it work when using another browser, Chromium, for instance? Do you have system-wide adblock through a router or pi-hole? If so, does it work with the computer connected directly to the modem? Is it a DNS issue? Can you change to an alternate DNS server (OpenDNS, Google, Yandex, Quad9 as examples) and see if that makes a difference? If you have a firewall, can you disable temporarily and see if that is the issue?


In most cases it just depends on the browser you are using.

So you expect to see the uploaded picture inside the circle? I would rather say it is a java script issue and how different browser run this code.