Strange behaviour of gamepad under Manjaro GNOME 20.2.1

Hello good people, I recently switched from Pop_OS! 20.10 to manjaro and so far everything seems good, RTX 2070 Super is working with the Nvidia drivers, my Games from Steam and GOG Run very well… I have Just one anoying issue: my gamepad (Steelseries Stratus Duo for what it is worth) hast two Problems:

  1. The X and Y Button are switched, they show up in the Steam Controller Layout properly but in Games they are Always Mixed Up (X working as the Y button and vice versa)

  2. Even more anoying: the Left and Right Trigger Buttons are not … there. They already Show Up empty in the Steam Controller Setup (where you can review and Change all Buttons and mapping/action ) and I cannot activate them there and also in Games I cannot bind them to any action.

However before the Switch, with Pop_Os, the Controller worked perfectly fine, so I was wondering If there is a package Missing that I can Install, or anything…

UPDATE: added a screenshot of the Steam Controller Layout overview with - what I think - is the problem.

Any help is much appreciated!

My laptop with Pop_OS! is out of commission right now, but should have a replacement coming soon ™. I’ll see if I can do some digging to see what they do differently in the meantime.

EDIT: Just looked and they do add some support for more controllers. No hardware ID’s for Steelseries, however. Just PS5 & Switch controllers.

You can try out their additions if you want. If it works, I’ll merge them in.

Before you begin, exit Steam completely.

  1. Make a backup of the original file. Otherwise, you will have conflicting files later:
    sudo mv /usr/lib/udev/rules.d/70-steam-input.rules /usr/lib/udev/rules.d/70-steam-input.rules.bak
    
  2. Save this file. For the next step, we’ll assume it’s in ~/Downloads/.
  3. Overwrite the original file with the file you just downloaded:
    sudo cp -i ~/Downloads/60-steam-input.rules /usr/lib/udev/rules.d/70-steam-input.rules
    

Now test out your controller and let me know if it works. Either way, remember to restore the backup of that file before the next stable update, otherwise there will be conflicting files and the update will fail.

To restore the original file, it’s just the reverse of the above:

sudo mv /usr/lib/udev/rules.d/70-steam-input.rules.bak /usr/lib/udev/rules.d/70-steam-input.rules
1 Like

thanks man!
I will give this a try tomorrow when back on my main machine and loop back any success/failure.

@Yochanan - thanks for providing the file - I tested it after a fresh restart of the PC but I was not able to see any difference.
Games I checked it with: Control, Deus Ex: Mankind Devided and SotTR

for additional information please see the info on the system as provided with inxi -Fxxxza --no-host

System:    Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 root=UUID=1c129e55-d397-4b1e-83c1-01091401aaf8 ro quiet splash 
           apparmor=1 security=apparmor resume=UUID=09510e04-6c77-4fd0-899d-3d502ad16b69 udev.log_priority=3 
           Desktop: GNOME 3.38.2 tk: GTK 3.24.24 wm: gnome-shell dm: GDM 3.38.2.1 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Gigabyte model: B550I AORUS PRO AX v: x.x serial: <filter> UEFI: American Megatrends v: F11p 
           date: 12/18/2020 
CPU:       Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) model-id: 71 (113) 
           stepping: N/A microcode: 8701021 L2 cache: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86277 
           Speed: 2196 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 2196 2: 2191 3: 1863 4: 1864 5: 2195 
           6: 2677 7: 1863 8: 1865 9: 2194 10: 2191 11: 2194 12: 2395 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU104 [GeForce RTX 2070 SUPER] vendor: Gigabyte driver: nvidia v: 455.45.01 
           alternate: nouveau,nvidia_drm bus ID: 08:00.0 chip ID: 10de:1e84 
           Display: x11 server: X.org 1.20.10 compositor: gnome-shell driver: nvidia resolution: <missing: xdpyinfo> 
           OpenGL: renderer: GeForce RTX 2070 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 direct render: Yes 
Audio:     Device-1: NVIDIA TU104 HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 08:00.1 chip ID: 10de:10f8 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 0a:00.4 chip ID: 1022:1487 
           Device-3: SteelSeries ApS SteelSeries Arctis 9 type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 5-4.1:10 
           chip ID: 1038:12c4 serial: <filter> 
           Sound Server: ALSA v: k5.9.16-1-MANJARO 
Network:   Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel port: f000 bus ID: 06:00.0 
           chip ID: 10ec:8125 
           IF: eno1 state: down mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: f000 bus ID: 07:00.0 chip ID: 8086:2723 
           IF: wlp7s0 state: up mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 214.93 GiB (23.1%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WDS100T3X0C-00SJG0 size: 931.51 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 111110WD temp: 44.9 C 
Partition: ID-1: / raw size: 914.01 GiB size: 898.66 GiB (98.32%) used: 214.93 GiB (23.9%) fs: ext4 dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 17.2 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3 
Sensors:   System Temperatures: cpu: 51.6 C mobo: N/A gpu: nvidia temp: 51 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 319 Uptime: 16m wakeups: 0 Memory: 15.64 GiB used: 2.81 GiB (18.0%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 Packages: pacman: 1376 lib: 449 flatpak: 0 Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.2.01

@Yochanan - you know what? I DID work. Don’t know how, but now I was able to mitigate the missing config fpor left and right trigger on my gamepad configuration from the picture in the original post.

Just did not try this step at first, my fault!
Thanks a lot man for the quick help.

I’m glad it worked. I’m going to merge those changes into game-devices-udev, you’ll see an update to 0.10-2 here shortly. Don’t forget to restore the backup of the original file as I outlined above.

Tip: When pasting terminal output, highlight it and use the Preformatted text </> button. I’ve done it for you this time. :wink: