Stop screen off after 10 min - no power management under KDE settings


I have a fresh install of Manjaro with KDE. (desktop PC)
After about 10 mins the screen goes off, it’s quite annoying, and I don’t find how to stop this.
I saw on the net that is should be apparently a “power management” section under settings, but there is not.


you mean system settings/ energy saving and screen energy saving?


I don’t have it, so i don’t know exactly how it has to be.
It seems i don’t have any way to control the screen standby/power off.

Under setting I have only screen locking control
“lock screen automatically” it it s unset and that s all.

Not important for me but i even don’t have “screensaver” settings.

so you dont have this:

no power management

Now i can upload pics so,
settings - no pm

is it a fresh install?
is the system up to date?

Please check if the powerdevil package got installed on your system, it’s required for power management in KDE…
Cheers, Eddy

Yes, fresh and up to date



Not installed

So just install this ?

yes install it, reboot and see if it helped

Now i have the power management settings !

Thank you all :+1:

the solution was from user @Oldhabbits , so mark it properly…
did you install the minimal version of kde? since the powerdevil was not installed by default?

This is my first install of Manjaro and it took me days to understand that i have a problem, i now i don’t remember if I choose a “minimal version of KDE”

I tried to remember if i uninstalled by mistake this package but i can’t figure out how this happen.

I see also that i don’t have screen brightness setting.
It has to be ?


at least its now fixed…
if you mean the screen brightness setting under the energy saving settings, its because i have a laptop … youre on desktop so you dont have it

Install kgamma5 ? This package contains a settings panel for adjusting the brightness, contrast,
and gamma-correction of a monitor.
Cheers, Eddy

This one is already installed
and it doesn’t give me brightness control

I have a message “This topic has been solved” so i don’t want to continue here.
If necessary I’ll open a new one.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.