Still getting sounds of notifications in Do Not Disturb mode

I’ve tried adjusted the settings to get rid of the sounds, to no avail:

[jr@fm ~]$ inxi -Fxxx
System:    Host: fm Kernel: 5.4.67-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: TUF B450M-PLUS GAMING v: Rev X.0x 
           serial: <superuser/root required> UEFI: American Megatrends v: 1002 date: 03/07/2019 
CPU:       Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ rev: 2 
           L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 118222 
           Speed: 2192 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 1: 2200 2: 2175 
           3: 2181 4: 2187 5: 2027 6: 2193 7: 2188 8: 2195 9: 2180 10: 2190 11: 1886 12: 2190 
           13: 2186 14: 2187 15: 2225 16: 2181 
Graphics:  Device-1: NVIDIA TU104 [GeForce RTX 2080] vendor: ASUSTeK driver: nvidia v: 440.100 
           bus ID: 07:00.0 chip ID: 10de:1e82 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nvidia resolution: 
           1: 1920x1080~60Hz 2: 1920x1080~60Hz s-dpi: 94 
           OpenGL: renderer: GeForce RTX 2080/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 direct render: Yes 
Audio:     Device-1: NVIDIA TU104 HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 07:00.1 chip ID: 10de:10f8 
           Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 09:00.3 chip ID: 1022:1457 
           Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo bus ID: 1-4:6 
           chip ID: 046d:0825 serial: 8D1EA6E0 
           Sound Server: ALSA v: k5.4.67-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK 
           driver: r8169 v: kernel port: f000 bus ID: 05:00.0 chip ID: 10ec:8168 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: 40:b0:76:5c:8c:4c 
Drives:    Local Storage: total: 1.36 TiB used: 62.35 GiB (4.5%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 500GB size: 465.76 GiB 
           speed: 31.6 Gb/s lanes: 4 serial: S4EVNG0M116780W rev: 1B2QEXM7 scheme: GPT 
           ID-2: /dev/sda type: USB vendor: Seagate model: Expansion size: 931.51 GiB 
           serial: NA8GPRR8 rev: 0707 scheme: MBR 
Partition: ID-1: / size: 109.37 GiB used: 26.10 GiB (23.9%) fs: ext4 dev: /dev/nvme0n1p3 
Swap:      ID-1: swap-1 type: partition size: 69.34 GiB used: 0 KiB (0.0%) priority: -2 
           dev: /dev/nvme0n1p6 
Sensors:   System Temperatures: cpu: 37.9 C mobo: N/A gpu: nvidia temp: 31 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 20% 
Info:      Processes: 341 Uptime: 5d 7h 28m Memory: 62.81 GiB used: 25.93 GiB (41.3%) Init: systemd 
           v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1267 Shell: Bash v: 5.0.18 
           running in: konsole inxi: 3.1.05 
[jr@fm ~]$ 

You also have to check the notification settings for the individual applications. Some applications ─ most notably Electron apps and GTK apps ─ don’t allow fine-tuning via the Plasma settings and need to have their notifications either turned off completely, or configured within the application itself.

Alright, I had configured applications to not show in DND mode—or that was the default—but I have now turned off to show popups and in history as well—although that is just to try to get them to not sound in DND mode¸ even though just ticking “do not show in DND mode” should be enough.