"Sticky" Panel Icons

I’m seeing an odd problem periodically. I can’t reproduce it on command, but seems to happen primarily after waking my device up from sleep at times.

Symptom: when moving the mouse over icons on the bottom panel it grabs them as if the mouse button had been clicked, and proceeds to drag it to a new location on the panel, off the panel, etc. I’ve confirmed the buttons aren’t stuck, etc. Have tried hitting Ctl / Shift / Alt, etc. just in case there was a key combination I wasn’t aware of to produce that behavior, but no luck. Once started I’ve not found a way to stop that behavior except a reboot which has fixed it every time, at least until it comes back later. Currently happens once or twice a week for me.

Anyway, not the worst problem in the world but just a little annoyance. I’ve looked through the Edit Mode for the panel, checked Configure Icons-Only Task Manager with no luck. Not really sure where else to dig? Curious if anyone had any thoughts, and happy to provide additional machine info if it’s helpful - thanks!

  Kernel: 6.6.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=eb6d89a1-a69d-4b37-80b7-e91afd2db1bd rw quiet
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
    v: 5.113.0 wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Info: dual core Intel Core i5-7300U [MT MCP] arch: Amber/Kaby Lake
    note: check speed (MHz): avg: 900 min/max: 400/3500
  Device-1: Intel HD Graphics 620 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:5916
    class-ID: 0300
  Device-2: IMC Networks SunplusIT Integrated Camera driver: uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-8:4
    chip-ID: 13d3:5682 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.10 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915
    resolution: 2560x1440~60Hz
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.3-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 620 (KBL GT2)
    device-ID: 8086:5916 memory: 15.01 GiB unified: yes
  Local Storage: total: 476.94 GiB used: 204.62 GiB (42.9%)
  Memory: total: 16 GiB note: est. available: 15.38 GiB used: 4.58 GiB (29.8%)
  Processes: 201 Power: uptime: 3d 22h 48m states: freeze,mem,disk
    suspend: deep avail: s2idle wakeups: 9 hibernate: platform
    avail: shutdown,reboot,suspend,test_resume image: 6.14 GiB
    daemons: upowerd,org_kde_powerdevil Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: 1348 pm: pacman pkgs: 1323 libs: 387 tools: pamac pm: flatpak
    pkgs: 25 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Bash v: 5.2.21
    running-in: konsole inxi: 3.3.32

A workaround may be locking the items/panel.

But its still sounds like a mouse problem to me.

Whether hard or soft ware … 'click’s are being activated somehow?


Nice thought on the locking workaround, thank you. Will do that now and see if at least helps mask whatever is going on at a minimum.

And I initially thought the same re: the mouse / touchpad being at the root of the problem. The thing I keep coming back to is that it only affects the lower panel as far as I can tell, however. I can move across and interact with all other windows and menus normally when it happens.

Fair enough. :thinking:

Another check - new user.
Thats an easy test for anything that might be funky with the original profile.
(technically if theres a problem deeper, with root etc, then it would still present, but it may be worth looking)

I’ve seen that happen before with (earlier versions of) Plasma, and it’s consistent and repeatable. It’s especially prone to happening when using the QuickLaunch widget.

I’m guessing it’s an old bug that somehow got reintroduced by recent code changes, whereby a click gets registered as a drop-&-drag operation. Pressing Esc usually remedies the issue.

Just my 1/50 €. :stuck_out_tongue:

1 Like

If it were so then … would it not have affected hundreds or thousands of others?

Dunno … I’m dealing with broken keys, which is a distro, not a DE problem.
Havent had one of those for a while. Maybe KDE 6 will make it happen.

Not everyone will be vocal about it, but it has been mentioned with regard to other distros in the past, and it was then identified as a KDE-specific bug — possibly in the Frameworks.

Count on it. :stuck_out_tongue: :smiling_imp:

I happen to have this key issue like I said … but mousing over the panel seems to work fine and I see no chirps about it elsewheres and … I think this user is on Stable so would be a few hits behind.

But sure … I guess we should just do the apple thing, say ‘bug’ about any random occurence of other software and smugly close discussion. Thats how science works.

I’ve recently been seeing some similar issues as the OP here myself on my own system, albeit not with regard to launcher icons, but with regard to mouse-over tooltips that won’t go away unless you mouse-over again, and some stickiness of visual objects being dragged around with the mouse and refusing to drop when you release the mouse button.

It also doesn’t happen every time. However, in the event of the QuickLaunch widget — which I’m not using on Manjaro, but I do still have a PCLinuxOS machine (which I rarely ever use and haven’t even used in years now) — it is consistent, and that is the issue others have reported as well.

I will however say this: never underestimate atmospheric issues. Non-enterprise-grade computer technology is relatively badly shielded against cosmic radiation and atmospheric ionization, and flipped bits happen a lot more often than people suspect.

So if that were the cause, then that makes it into a hardware issue, albeit not one that the manufacturers consider to be a bug, because the device wasn’t marketed as containing ECC technology.

Linus Torvalds has actually still fairly recently been complaining about the absence of ECC in consumer-grade computers. It is a thing, and I’ve experienced quite a few glitches myself here whenever there’s a storm outside. Mind you, I’m not talking of a thunderstorm, because that actually neutralizes the ionization of the atmosphere. I’m talking of a storm that’s not followed by lightning.

And the above is science, by the way. :wink:

So … your answer is some sort of combination of “Of course KDE Bad” and “Ionic storms change electrons somewhere and cause the bugs”?

Maybe im stupid.

Now you’re exaggerating. If I really thought it was that bad, then I wouldn’t have been using it for now well over 24 years.

I am merely looking for an explanation as to what causes OP’s problem, and one potential explanation is the historically true fact that there has effectively been such a “stickiness” bug in Plasma in the past.

So I’m not saying that this is effectively the cause of the issue, but it’s always possible that the bug has returned in the most recent version of the KDE Frameworks as used in the Plasma edition of Manjaro Stable.

Couple of quick notes:
Yes - I am on stable branch.
Yes - When the issue appears and I mouse over and grab one of those quick launch icons accidentally, hitting ESC does cancel the effect - but for that grab only. I can immediately and repeatedly grab them over and over without clicking any mouse/touchpad buttons.

Not the end of the world, and maybe it will be sorted out for me once KDE 6 arrives. I’ve actually not had luck in locking the panel yet, so maybe those settings are hiding in plain sight for me?

In either case, I think my next move is to remove and then re-add the Icons Only Task Manager widget and see if that has any effect. Thanks all!

qdbus org.kde.plasmashell /PlasmaShell evaluateScript "lockCorona(true)"

Change that to “false” in order to unlock them again when needed.

Super helpful - thank you for the heads up on the qdbus options for interacting with KDE. I did the Panel replacement earlier today and am waiting to make further changes until I give it a while to see if that made any difference. If the issue returns I plan to lock it down. Much appreciated everyone!

1 Like