Steam: “You are missing the following 32-bit libraries, and Steam may not run:”

I am looking at this here: Steam (runtime) boot issue “You are missing the following 32-bit libraries, and Steam may not run:”
and since yesterday (2022-05-30T07:00:00Z) I am having the exact same issue after a system update. Not much was updated, mostly monguhud if I recall correctly. I went through whatver was said in that article I linked, and there no solution was given. Was this just something intermittent which was fixed with a later update? Right now this is broken for me.


This is with Wayland or/and X11 on a RX6400 which worked fine just two days ago.

you have to disable mangohud

see before

Not its not mangohud. Uninstalled it and all. No change this happens when I start steam - at that point no mangohud is yet loaded. So, can’t be that.

~> steam                                                                                                                                     [31246]: Running Steam on manjarolinux 21.2.6 64-bit[31246]: STEAM_RUNTIME is enabled automatically[31321]: Steam runtime environment up-to-date![31246]: Error: You are missing the following 32-bit libraries, and Steam may not run:[31246]: Steam client's requirements are satisfied

Try maybe this:

LD_PRELOAD=/usr/lib/ steam

Do you have lib32-glibc (2.35-5) installed?

It’s there

~ > ls -lha /usr/lib32/*                                                                                                                                                                   
 rw-r--r-- 1 root root  252 May 13 07:57 /usr/lib32/
-rwxr-xr-x 1 root root 2.2M May 13 07:57 /usr/lib32/

 ~ > sudo ldd /usr/lib32/                                                                                                                                                                      
/usr/lib32/ => /usr/lib/ (0xf7f02000) (0xf7f00000)

~ > /usr/lib32/                                                                                                                                                                          

GNU C Library (GNU libc) stable release version 2.35.
Copyright (C) 2022 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
Compiled by GNU CC version 12.1.0.
For bug reporting instructions, please see:

Searchpath missing?

Does this show the lib32 folder?
ldconfig -v | grep lib32

sudo ldconfig -v | grep ':'                                                                                                                                                           ldconfig: Path `/usr/lib64' given more than once
(from <builtin>:0 and <builtin>:0)
ldconfig: Can't stat /usr/libx32: No such file or directory
/opt/android-sdk/tools/lib: (from /etc/
/usr/lib/libfakeroot: (from /etc/
/usr/lib32: (from /etc/
/usr/lib/opencollada: (from /etc/
/usr/lib/openmpi: (from /etc/
/usr/lib: (from <builtin>:0)
/opt/android-sdk/tools/lib/x86_64: (hwcap: 0x0000000000000002) (from /etc/

Something fishy going on here, but its there

What if you try steam --reset?

Imagine that. That worked. Thx

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.