Steam wont connect to network

I have a problem with steam that I have been working on for the past few hours.

At some point before this I reset my bios, I doubt this is related, but it’s worth mentioning.

It won’t connect to the steam network.

There have been a few times where I was able to log in, but once inside, nothing was connecting. No updates, I could not post in the forums, I can’t view my profile, it doesn’t even show my avatar.

I tried exiting the beta, but It can’t download the new client. It just tells me steam needs to be connected to a network. Now I am stuck.

What I have tried.

3 wireless networks, 1 wired network

Removing and reinstalling the steam client

2 other computers (both logged me in as normal), one with manjaro and one with windows.

At this point I can’t even open the steam client, because it attempts to update, but can’t.

Any suggestions?

This is the terminal output.

I can go to any of the links in the terminal, and download the files.

I also renamed .local/share/Steam/ to something else, and regenerated the folder.
It still didn’t work.

Running Steam on manjarolinux 21.1.1 64-bit
STEAM_RUNTIME is enabled automatically
Steam runtime environment up-to-date!
Steam client's requirements are satisfied
WARNING: Using default/fallback debugger launch
[2021-09-04 06:29:34] Startup - updater built Aug 31 2021 20:57:58
[2021-09-04 06:29:34] Loading cached metrics from disk (/home/admin/.local/share/Steam/package/steam_client_metrics.bin)
[2021-09-04 06:29:34] Using the following download hosts for Public, Realm steamglobal
[2021-09-04 06:29:34] 1., /client/, Realm 'steamglobal', weight was 100, source = 'update_hosts_cached.vdf'
[2021-09-04 06:29:34] 2., /client/, Realm 'steamglobal', weight was 100, source = 'update_hosts_cached.vdf'
[2021-09-04 06:29:34] 3., /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
[2021-09-04 06:29:34] Verifying installation...
[2021-09-04 06:29:34] Unable to read and verify install manifest /home/admin/.local/share/Steam/package/steam_client_ubuntu12.installed
[2021-09-04 06:29:34] Verification complete
[2021-09-04 06:29:34] Downloading update...
[2021-09-04 06:29:34] Checking for available updates...
[2021-09-04 06:29:34] Downloading manifest:
[2021-09-04 06:29:34] Download failed: http error 0 (
[2021-09-04 06:29:34] Downloading manifest:
[2021-09-04 06:29:35] Download failed: http error 0 (
[2021-09-04 06:29:35] Downloading manifest:
[2021-09-04 06:29:35] Download failed: http error 0 (
[2021-09-04 06:29:35] DownloadManifest - exhausted list of download hosts
[2021-09-04 06:29:35] failed to load manifest from buffer.
[2021-09-04 06:29:35] Failed to load manifest
[2021-09-04 06:29:35] Error: Download failed: http error 0
[2021-09-04 06:29:35] Saving metrics to disk (/home/admin/.local/share/Steam/package/steam_client_metrics.bin)
[2021-09-04 06:29:35] Error: Steam needs to be online to update. Please confirm your network connection and try again.
[2021-09-04 06:29:46] Shutdown
src/tier0/threadtools.cpp (3580) : Assertion Failed: Illegal termination of worker thread 'Thread(0x0x574f0f30/0x0xec1ffa'

You can try to force the use of other DNS server and reboot to see if it fixes the issue.

Thanks for the reply,
I tried using OpenDNS, this did not fix the issue.

I restored a timeshift snapshot from a couple of days ago, and it works now. I wish I knew what went wrong.

Also, whoever decided to include timeshift in this distro…Big Thanks! I would have ended up nuking this install today.

Same problem here with steam after update. Nothing changes except update. I don’t want to timeshift restore. Any suggestions?

1 Like

Steam beta solved the problem for me.


Did you have a look here at the Stable Update page?

Under “If Steam breaks completely and only shows a black screen:”.

EDIT: Just checked my steam & also got the black screen. Beta fixed it. Always remember to check the stable update page before updating.

Thank you for the info.
I was just trying to give feedback to my problem I reported and the working solution method.

This was yesterday before the update, and I was already in the beta. The only thing I updated yesterday was visualstudiocode-bin.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.