Steam or lutris games do not launch on AMD dGPU


When I launch a game from Windows that requires the dGPU it crash, I tested with League of Legends(LoL) on Lutris( here output on Lutris ) and Darwing Project on Steam ( here output on Steam ).
I testing with a hybrid laptop(AMD Radeon R7 260 and Intel) the output of lspci -k | grep -EA3 'VGA|3D|Display' is:

    00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
        Subsystem: Toshiba Corporation Device f903
        Kernel driver in use: i915
        Kernel modules: i915
03:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445 / 530/535 / 620/625 Mobile]
        Subsystem: Toshiba Corporation Radeon R7 M260
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu

When I run LoL on Lutris it crash before lauching the client and Darwing on Steam it crash after accepted the window of “Easy Anti-cheat”, those errors and some research make me thing of a possible gpu problem but I already check amdgpu driver and the support of vulkan for my dGPU which belong to Sea Island card(CIK) and both brings with support for my dGPU.
I’m executing the apps or games with this command:
DRI_PRIME=1 VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/amd_icd32.json:/usr/share/vulkan/icd.d/amd_icd64.json [program]

Here are some dmesg from journalctl -a
Here is the output of Xorg.conf and some relevant point is:

 [    43.458] (II) AMDGPU(G0): [DRI2] Setup complete
[    43.458] (II) AMDGPU(G0): [DRI2]   DRI driver: radeonsi
[    43.458] (II) AMDGPU(G0): [DRI2]   VDPAU driver: radeonsi

There point the successful setup of DRI2 and before DRI3 is loaded but never shows “Setup complete”

System info inxi -Fxxxz:

System:    Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: TOSHIBA product: N/A v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: TOSHIBA model: CA10SU serial: <filter> UEFI: TOSHIBA v: 1.40 date: 12/05/2014 
Battery:   ID-1: BAT0 charge: 25.6 Wh condition: 25.6/44.7 Wh (57%) volts: 16.1/14.8 model: PEGA G71C000HS110 type: Li-ion 
           serial: N/A status: Not charging 
CPU:       Info: Dual Core model: Intel Core i5-4210U bits: 64 type: MT MCP arch: Haswell rev: 1 L2 cache: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19162 
           Speed: 1696 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 1696 2: 1696 3: 1696 4: 1696 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Toshiba driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0a16 
           Device-2: Chicony TOSHIBA Web Camera - HD type: USB driver: uvcvideo bus ID: 2-6:3 chip ID: 04f2:b446 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: amdgpu,intel resolution: 1366x768~60Hz s-dpi: 96 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 20.3.1 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: Toshiba driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           chip ID: 8086:0a0c 
           Device-2: Intel 8 Series HD Audio vendor: Toshiba driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:9c20 
           Sound Server: ALSA v: k5.9.16-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: Lite-On driver: ath9k v: kernel 
           port: f040 bus ID: 02:00.0 chip ID: 168c:0036 
           IF: wlp2s0 state: up mac: <filter> 
Drives:    Local Storage: total: 298.09 GiB used: 43.03 GiB (14.4%) 
           ID-1: /dev/sda vendor: Western Digital model: WD3200BEKT-60PVMT0 size: 298.09 GiB speed: 3.0 Gb/s serial: <filter> 
           rev: 1A01 
Partition: ID-1: / size: 292.12 GiB used: 43.03 GiB (14.7%) fs: ext4 dev: /dev/sda2 
           ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A gpu: amdgpu temp: 40.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 218 Uptime: 6h 57m wakeups: 1 Memory: 7.69 GiB used: 5.82 GiB (75.7%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 clang: 11.0.0 Packages: 1319 pacman: 1310 snap: 9 Shell: Bash v: 5.1.0 running in: konsole inxi: 3.2.01

So I been doing some research work for too long and config the gpu but now I run out of ideas, any help would be great, thanks.

EDIT: By the way I already try LoL with snap and crash in the same way as lutris the output is less detailed

Relevant config files: Xorg.conf , mkinitcpio.conf, grub and I’m using linux59 kernel.

And another chuck of information appear when a I run xrandr --listproviders with:

Providers: number : 2
Provider 0: id: 0x47 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 4 associated providers: 1 name:Intel
Provider 1: id: 0x89 cap: 0xd, Source Output, Source Offload, Sink Offload crtcs: 0 outputs: 0 associated providers: 1 name:AMD Radeon R7 M260 @ pci:0000:03:00.0

and then xrandr --setprovideroutputsource 0x47 0x89:

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  35 (RRSetProviderOutputSource)
  Value in failed request:  0x89
  Serial number of failed request:  16
  Current serial number in output stream:  17

That show up for both 0x47 and 0x89