Steam missing 32-bit library

After some time without using Steam decided to check out a new game release. Then this message appears:

Error: You are missing the following 32-bit libraries, and Steam may not run:

my actual lib32 for pulseaudio is: (latest update)

tried the following to solve thiss:

re-installing steam (removing all dependencies)
‘steam --reset’ (after re-installing)
running ‘steam-runtime’ (also resetting)
running ‘steam-native’ (also resetting)

any idea of what else to check?

How did you install steam?

Are you in a partial upgrade state?

sudo pacman-mirrors -f && sudo pacman -Syu

You seem to be missing Steam Linux Runtime 2.0 (soldier). Normally it will be installed automatically if a game requires it. You can install it manually under Tools from the sidebar.

❯ find ~/.local/share/Steam/ -iname "*"

can’t open steam, not sure how to install

How did you install steam?

thru pacman, just “-S steam”

Are you in a partial upgrade state?



looks like I have it, don’t know why Steam not initiating

You can install it manually under Tools from the sidebar.

what side bar? inside Steam?

Tried copying

cp /usr/lib32/pulseaudio

but Steam does not launch, get the same message (missing libpulsecommon-12.2)

DO NOT do that. Revert it.

We’re going to need more info than that. Please run steam from the terminal, reproduce the issue, copy the output, use a pastebin service and link it here.


Here’s the results from the terminal:

Unfortunately, the log isn’t very helpful. However, you could try searching the internet for the error message:

UpdateUI: skip show logodlmopen failed: cannot open shared object file: No such file or directory

I wish I could be of more help. I play games via Steam all the time and rarely have issues. :man_shrugging:

No prob. Never had an issue with Steam before, this one’s got me thinking… Thanks for the help and attention anyways.