Steam games won't launch on X session


I have a question, which something like similar to this, but with different behavior (it’s solution won’t work).
I have Gnome Wayland and separated IceWM X session for running games, which won’t playable perfectly on Wayland session, and also without Gnome effects. My laptop is hybrid AMD-NVidia. Before I installed proprietary nvidia driver (yesterday), games runs pefrectly on both sessions with AMD driver and nouveau driver.
After replacing nouveau with nvidia-470, I have possibility to use Wayland session with it, and also use nvidia features for work. Games runs perfectly, but with some issues related to Wayland. I have tried to run same games on my separated IceWM X session with steam, and for Proton games I’ve got stuck on Preparing to launch... window. Same thing appears with Gnome X session – stuck on this window. Also it happens with same window when I run only one X session, without Wayland. Native games runs, and playable.
Running steam in terminal I’ve got this:
GameAction [AppID 282440, ActionID 1] : LaunchApp changed task to ProcessingInstallScript with ""
and nothing other after it.

System info:

  Kernel: 5.13.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  Desktop: GNOME 40.3 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec0xxx 
  v: N/A serial: <filter> 
  Mobo: HP model: 86D5 v: 96.15 serial: <filter> UEFI: AMI v: F.01 
  date: 08/15/2019 
  ID-1: BAT0 charge: 45.5 Wh (100.0%) condition: 45.5/45.5 Wh (100.0%) 
  volts: 12.7 min: 11.6 model: Hewlett-Packard Primary status: Full 
  Info: Quad Core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen rev: 1 cache: L2: 2 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 33550 
  Speed: 2758 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 
  1: 2758 2: 2762 3: 1231 4: 1289 5: 1208 6: 1231 7: 1231 8: 1231 
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] 
  vendor: Hewlett-Packard driver: nvidia v: 470.63.01 bus-ID: 01:00.0 
  Device-2: AMD Picasso vendor: Hewlett-Packard driver: amdgpu v: kernel 
  bus-ID: 05:00.0 
  Device-3: Quanta HP TrueVision HD Camera type: USB driver: uvcvideo 
  bus-ID: 3-1:2 
  Display: wayland server: 1.20.13 compositor: gnome-shell driver: 
  loaded: amdgpu resolution: <missing: xdpyinfo> 
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.41.0 
  5.13.10-1-MANJARO LLVM 12.0.1) 
  v: 4.6 Mesa 21.1.6 direct render: Yes 
  Device-1: NVIDIA vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
  bus-ID: 01:00.1 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Hewlett-Packard driver: snd_pci_acp3x v: kernel bus-ID: 05:00.5 
  Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus-ID: 05:00.6 
  Sound Server-1: ALSA v: k5.13.10-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: no 
  Sound Server-4: PipeWire v: 0.3.33 running: yes 
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: rtw_8822ce v: N/A port: e000 
  bus-ID: 03:00.0 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: N/A port: d000 bus-ID: 04:00.0 
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 
  bus-ID: 1-4:3 
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends 
  Local Storage: total: 1.14 TiB used: 459.86 GiB (39.3%) 
  ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 238.47 GiB 
  temp: 51.9 C 
  ID-2: /dev/sda vendor: Western Digital model: WD10SPZX-80Z10T2 
  size: 931.51 GiB 
  ID-1: / size: 75.48 GiB used: 47.5 GiB (62.9%) fs: ext4 
  dev: /dev/nvme0n1p4 
  ID-2: /boot/efi size: 256 MiB used: 61.4 MiB (24.0%) fs: vfat 
  dev: /dev/nvme0n1p1 
  ID-3: /home size: 57.85 GiB used: 23.87 GiB (41.3%) fs: ext4 
  dev: /dev/nvme0n1p5 
  ID-1: swap-1 type: partition size: 5 GiB used: 2.58 GiB (51.7%) 
  dev: /dev/nvme0n1p6 
  System Temperatures: cpu: 64.2 C mobo: 55.0 C gpu: amdgpu temp: 64.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 329 Uptime: 22h 48m Memory: 9.64 GiB used: 6.89 GiB (71.5%) 
  Init: systemd Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1566 
  Shell: Zsh v: 5.8 inxi: 3.3.06