Steam Games / Vulkan not running properly anymore

If you mean amdgpu-pro (which you should not use anyways) … then yes, it does not appear in the package list. but as shown in the following quote, you still have amdgpu-git.
And none of this means ‘mhwd is still in control’ … we will revisit this below by force reinstalling the proper driver profile.

Probably not a good idea.

Like this - you probably dont want this.

sudo pacman -Syu xf86-video-amdgpu
sudo mhwd -f -i pci video-linux

(yes to replacement, reboot and check functions)

Yep, I have one. Not the latest, tbh, but maybe it will work getting back.

CSCS is more experienced than me… maybe try timeshift rollback later, if nothing helps.

From my opinion, if absolute nothing is changed… its probably the hardware.

Temps, powerdraw (power supply), gpu power connector (i know the chances are low), did you or someone else touched the Tower Case, maybe a connector not 100% stable or your GPU isnt no longer 100 perfect in the PCI-E Slot? I hope no real damage… as i said, steam has silence/invisible launcher updates and can only be detected after booting again in Steam and you see the launcher boot window changed for few seconds but then… you can easy MISS THIS FEEDBACK.

When there are no autoupdates elsewhere, why shouldn’t your GPU run into issue, when nothing changed… besides are hardware problem?

sudo pacman -Syu xf86-video-amdgpu
sudo mhwd -f -i pci video-linux

Still not working :confused:

Whats not working, how?

what does

vulkaninfo --summary

show now ?

If I start a game with steam I still get the error CREATEDXGIFactory: FAILED

ERROR: [../mesa-23.3.5/src/amd/vulkan/radv_physical_device.c:1740] Code 0 : Could not open device /dev/dri/renderD128: Permission denied (VK_ERROR_INCOMPATIBLE_DRIVER)
ERROR: [Loader Message] Code 0 : setup_loader_term_phys_devs:  Failed to detect any valid GPUs in the current config
ERROR at /usr/src/debug/vulkan-tools/Vulkan-Tools-1.3.269/vulkaninfo/./vulkaninfo.h:237:vkEnumeratePhysicalDevices failed with ERROR_INITIALIZATION_FAILED

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

I just had to install the amdgpu-experimental via pamac, reboot and it works now.

Just found out about this, but I don’t now if I should even try it.

I dont know how youve broken vulkan.
I do notice that you have vulkan-intel which you probably should not.

The package is just an ‘easy’ way to add a few boot options to make AMDGPU funcitonal on early GCN cards it would not otherwise be active for (sea islands, etc).
You are already using amdgpu.
That package would do nothing for you.

Extra thought:
Maybe some bad files/options in /etc/X11/* ?

@wildschweinmann Please…

I wish I knew.

How do I find out?

Something like

ls /etc/X11/*

Would list items.

Somewhere in there would be my guess. Installing proprietary drivers is never the right answer to a problem like this. If you’re not able to undo whatever you did then hopefully you have a Timeshift backup…

Timeshift is your friend.

My guess, you changed something and just can’t remember or you maybe have data corruption… maybe unstable RAM settings, wrong RAM Timings in the BIOS is possible… who knows.

Are you 100% sure, there is no automatic updates activated somewhere else?

Do you had system freezes, that maybe lead to additional data corruption?

I used my Timeshift backup and everything is working again. I am absolutely sure I did not change something, and no automatic updates except Steam itself.

Thank all of you for helping me!

1 Like

Hi team,
i wanted to say, that i have the same problem like op.
I have nothing changed, only updated to the newest Manjaro Build ( 1 day ago) :pensive:

Is there maybe an incompatibility between new Mesa Drivers or Vulkan with the newst update?

Does anybody have the same issues?

If you need additional infos, kindly tell me, i will provide them

Many thanks

Always system Info’s:
inxi --admin --verbosity=7 --filter --no-host --width

1 Like

Hi Kobold ! Thank you very much for this command :slight_smile:

Wanted to say that the newest update today (a small update) and changing my Kernel from the unsupported LTS 6.4 to LTS 6.6 fixed the problem for me.

Thanks again! :slightly_smiling_face:

Point of information …
6.4 was/is not LTS (long term support) … or else it would have existed for longer than a few months.

Always keep your system up to date. 6.4 reached its end of life about 6 months ago.
(this also means it could not be the same issue as OP, as their opening inxi shows 6.6)

1 Like

How about… --verbosity=8 = Show us all the things! :grin:

Hi cscs, thank you for your feedback.

Good to know! I must have overlooked something during the kernel installation

Thank you all for your support! :slight_smile: