Steam friends menus are not working

After updating two days ago, I noticed that if I open menus from steam friends, like changing my status from online to invisible, away, offline or right click a friend to open the popup menu to send message, open profile, join game etc, the menus, along with the entire steam friend window, become unresponsive and stuck on my screen permanently on top of other windows unless I exit steam. A little more explanation, I can move steam friends window around, but I can’t do anything other than that, it ignores all clicking. I can, however, close the window from taskbar, closing it doesn’t resolve the stuck popup menu. The rest of steam client is still working fine and as intended.

  Kernel: 5.15.81-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/vmlinuz-5.15-x86_64
    root=UUID=c9c37c7e-6f11-49ba-be3c-3b2cd7015bc0 rw quiet
  Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: P5QD TURBO v: Rev 1.xx
    serial: <superuser required> BIOS: American Megatrends v: 0301
    date: 08/04/2009
  Info: model: Intel Xeon X5460 bits: 64 type: MCP arch: Penryn level: v1
    built: 2008 process: Intel 45nm family: 6 model-id: 0x17 (23) stepping: 6
    microcode: 0x60F
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 12 MiB desc: 2x6 MiB
  Speed (MHz): avg: 3166 min/max: N/A cores: 1: 3166 2: 3166 3: 3166 4: 3166
    bogomips: 25339
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GK107 [GeForce GTX 650] vendor: Micro-Star MSI
    driver: nvidia v: 470.161.03 alternate: nouveau,nvidia_drm non-free:
    series: 470.xx+ status: legacy-active (EOL~2023/24) arch: Kepler
    code: GKxxx process: TSMC 28nm built: 2012-18 pcie: gen: 2 speed: 5 GT/s
    lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:0fc6 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: N/A
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1280x1024 s-dpi: 95 s-size: 342x270mm (13.46x10.63")
    s-diag: 436mm (17.15")
  Monitor-1: VGA-0 res: 1280x1024 hz: 60 dpi: 96
    size: 338x270mm (13.31x10.63") diag: 433mm (17.03") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 470.161.03 renderer: NVIDIA GeForce GTX
    650/PCIe/SSE2 direct render: Yes
  Device-1: Intel 82801JI HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3a3e class-ID: 0403
  Device-2: NVIDIA GK107 HDMI Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0e1b class-ID: 0403
  Device-3: Creative Labs CA0106/CA0111 [SB Live!/Audigy/X-Fi Series]
    driver: snd_ca0106 v: kernel bus-ID: 04:00.0 chip-ID: 1102:0007
    class-ID: 0401
  Sound API: ALSA v: k5.15.81-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.61 running: yes
  Device-1: Qualcomm Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet
    vendor: ASUSTeK driver: ATL1E v: N/A modules: atl1e pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: dc00 bus-ID: 02:00.0 chip-ID: 1969:1026
    class-ID: 0200
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Local Storage: total: 2.27 TiB used: 317 GiB (13.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX200SSD1
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: MU03 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD10EADS-00M2B0
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
    type: N/A serial: <filter> rev: 0A01 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: HGST (Hitachi) model: HTS541010B7E610
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 1A01 scheme: MBR
  ID-1: / raw-size: 100 GiB size: 97.87 GiB (97.87%) used: 30.8 GiB (31.5%)
    fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-c33bd1cc-2a88-4ba0-b3fa-fdb5cff3e252
  ID-2: /boot raw-size: 1022 MiB size: 987.4 MiB (96.62%)
    used: 77.3 MiB (7.8%) fs: ext4 dev: /dev/dm-1 maj-min: 254:1
    mapped: luks-3cfeeb83-314b-4455-b048-f2047a401f75
  ID-3: /home raw-size: 364.75 GiB size: 357.95 GiB (98.13%)
    used: 131.51 GiB (36.7%) fs: ext4 dev: /dev/dm-2 maj-min: 254:2
    mapped: luks-7c011dbe-6e94-4a73-87d7-1c41cd8ce19f
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 10 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 39.5 C mobo: 35.0 C gpu: nvidia temp: 37 C
  Fan Speeds (RPM): cpu: 1259 psu: 0 case-1: 0 case-2: 0 gpu: nvidia fan: 40%
  Power: 12v: 12.38 5v: N/A 3.3v: 3.33 vbat: N/A
  Processes: 222 Uptime: 46m wakeups: 0 Memory: 7.76 GiB used: 2.72 GiB (35.0%)
  Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1524 libs: 460
  tools: pamac Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.24


It is a steam graphical glitch. Reset steam and it should be solved.

Hello, what do you mean by resetting? Same issue popped up for me as well and I cannot get rid of it by restarting Steam or my PC.

Ok so I reinstalled the package and it fixed itself :grinning:

Next time type this in the terminal:

steam --reset

It resets the configs und the steam core elements.

1 Like

Reset did literally nothing, so I just reinstalled steam, which worked for me like it did for nooks.

Right… You forgot to tell us about everything you did before you posted here and before you tried reinstalling.

Reset does indeed do something.

I don’t think that word means what you think it means.

Right… see above.

All reinstalling Steam does is install the same files you already had in the system.

Thing is, the steam package just installs a stub / launcher that downloads and installs itself in your Home directory.

Moral of the story:

steam --reset does something. Reinstalling the package should do nothing.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.