Steam doesn't launch when running NVIDIA

I’ve just installed optimus-manager on my Manjaro XFCE machine to switch between Intel & NVIDIA graphics, because I couldn’t really play Steam games with Intel alone.

But when I try to launch Steam after switching to NVIDIA, nothing happens. If I try to launch it via terminal, I get this error:

  • Running Steam on manjarolinux 21.0.1 64-bit
  • STEAM_RUNTIME is enabled automatically
  • Pins up-to-date!
  • Steam client's requirements are satisfied
  • WARNING: Using default/fallback debugger launch /home/[my username]/.local/share/Steam/ubuntu12_32/steam

I’ve already installed lib32-nvidia-utils, but the problem persists.

It works perfectly as intended if I switch back to Integrated (i.e. Intel-only) mode, but that defeats the purpose of installing optimus-manager, of course.

Here’s more in-depth info about my machine, if it helps:

  • OS: Manjaro Linux x86_64
  • Host: HP ENVY TS 14 Sleekbook 0888100000305B0000
  • Kernel: 5.11.10-1-MANJARO
  • Shell: bash 5.1.0
  • Resolution: 1366x768
  • Terminal: xfce4-terminal
  • CPU: Intel i5-4200U (4) @ 2.600GHz
  • GPU: Intel Haswell-ULT
  • GPU: NVIDIA GeForce GT 740M

Really appreciate your help. Thanks a lot!

does prime-run steam work? :thinking:

Not familiar with Optimus Manager, but do you reboot after switching video card?

Hmm, it says command not found. Is there a package I need to install for prime-run? Thanks!

It logs you out, but as far as I can tell, it doesn’t reboot.

Pretty sure you can set launch options for the game you want to use NVIDIA with and type prime-run %command%, then the game will launch with NVIDIA regardless of if you’re currently using Intel graphics.

Are you sure you have the correct nvidia drivers installed? you should have the video-hybrid-intel-nvidia-prime driver,thats come with the prime-run command to let you use the nvidia card when you want it.

When I read this I guess he made a custom driver install. Also:

I doubt you enable and disable hardware on the fly… so guess what you need to try when you switch a card.

it comes with optimus manager if you installed it correctly

Let start over, how did you install your Nvidia drivers?

NVIDIA PRIME drivers are not for this OLD GPU. Sorry.

You have to switch to free drivers or try bumblebee legacy.