Steam crashes mid games

  1. What are the versions of the following you’re currently on?
    • kernel
    • steam
    • gpu-trace
  2. Have you tried creating a new user already (E.G. pungentstentch2), logging in there and see if it happens there as well?


Hi, thanks for answering and sorry for the delay, busy days. I am only working now to test it on 5.10, still same issue even with a clean new user.

and try again…


pamac install gpu-trace
Warning: gpu-trace is only available from AUR
Cloning gpu-trace build files...
Checking gpu-trace dependencies...
Warning: gpu-trace-2.5-2 is up to date -- skipping
Nothing to do.
Transaction successfully finished.

I tested after this with Doom Eternal,Left 4 Dead(native) and WH40k Inquisitor: Martyr. Steam crashed after a while, same error as first post.

Have you already:

  • Right click on Game in your Steam Library
    • Properties
    • Local Files
    • Verify Integrity of Game Files
  • Contacted Steam Support?

(Sorry but I can’t help you any further than that)


I tried Hades and the error this time is different…

Installing breakpad exception handler for appid(steam)/version(1628551241)
Installing breakpad exception handler for appid(steam)/version(1628551241)
Installing breakpad exception handler for appid(steam)/version(1628551241)
***** OUT OF MEMORY! attempted allocation size: 402653184 ****
src/tier0/memstd.cpp (2489) : Fatal Assertion Failed: OUT OF MEMORY
src/tier0/memstd.cpp (2489) : Fatal Assertion Failed: OUT OF MEMORY
src/tier0/memstd.cpp (2489) : Fatal assert; application exiting
src/tier0/memstd.cpp (2489) : Fatal assert; application exiting
Installing breakpad exception handler for appid(steam)/version(1628551241)
assert_20210811115700_2375.dmp[41100]: Uploading dump (out-of-process)

Please read this and adapt and if that doesn’t help, Contact Steam Support


Thank you for your help. I won’t be putting up some swap, with 32 GB RAM I think I suffice, anyway I’ll keep trying to see how to fix this. Meanwhile no steam games for me :frowning:

Please read the wiki article again, especially this bit:

Do I Need Swap

That is a question that cannot be answered without having a look at your configuration and even with plenty of available memory, it is often used as a safety net or even sometimes due to specific application requirements so have a look at the following non-exhaustive list:

  • If you use hibernation: yes, you need swap!
  • If you have services that are not always active, but are still running all the time: yes, you need swap!
  • If you have an application that allocates virtual memory directly for temporary storage instead of RAM: yes, you need swap!
  • If you have an application that has a memory leak: yes, you need swap!
  • If you have a server with 1TB of RAM that you’re using as a desktop without applications allocating virtual memory or having memory leaks: No, you don’t need swap!


1 Like

I heard there is a memory leak issue with nvidia 470.57.02 driver (I hope they fix it in version 470.63.01). Although you’ve said that it also affects an old left4dead game, but still having swap is a must. You can watch your memory usage while playing to make sure that’s the case.

PS: I’m using nvidia card and nvidia 470.57 too, but I don’t have any memory leak problem tho.

Hi, Installed some swapon with a swapfile. Issue appears solved on some games

/swapfile file   6G   0B   -2

Still persists on others, like Drake Hollow or Doom Eternal, where the error is the same as the start of the thread

RunCommand: failed to run command: gpu-trace --get-tracing-status

gpu-trace only gets called if something else is wrong… It’s a symptom, (runny nose) not the disease (cold), so what other info can you share?


The only thing I have left is steam crash dumps, but I don’t know how to read them. Also, swap wasn’t a workaround, all games make steam crash, only it takes more time (about an hour more or less now), :man_shrugging:

You never replied to this:

And that’s my last idea as I don’t even use Steam, so if that:

  • doesn’t solve your problem, open a support case with Steam and send them their own crashlogs.
  • does solve your problem, I might have a workaround for you.


Yes I tried that, I answered in post 5, no luck with new user, already sent a steam ticket, hope it can clear things up.

Thanks for your help.

1 Like

My apologies: didn’t remember that. Too many concurrent issues I’m trying to solve too late at night…

:zzz: :bed: :first_quarter_moon_with_face:

Hi, I’m on Arch but I’ve been having pretty much the same exact problem for months.

Disabling the Steam Overlay helps (Crash every 3-4 hours instead of 1-2) but the problem persists, even if I leave steam running over night with no games open, it will crash with out of memory.

I’ve left a “free -m” dumping to a log file every 10 seconds and my available memory never even dipped below 16 GiB, but steam still crashes when trying to allocate exactly 4 GiB.

I’m on an AMD card with mesa drivers too, which is different to pungentstentch’s setup too.

Sounds like a 32-bit problem and definitely needs Steam’s intervention, so both of you, please read this:

especially the What’s this upstream / downstream business?

and then file a bug upstream…


Well I’d been doing more testing and apparently it was caused with some weird issue with Mangohud. As soon as I stopped using it steam stopped crashing at all.

I tried to clean and rebuild mangohud but the issue persists. So I guess I’ll wait until they fix it.

Thanks everyone for the help.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.