Startx returns (EE) no screens found after update

Before rebooting, I tried installing a package via Pamac when I was prompted to install new kerel version and update packages to work on it. That resulted in an error. After booting into Manjaro from GRUB, all I get is the motherboard logo, and if I remove the quiet flag from boot script, it gets stuck at

[ OK ] Started CUPS Scheduler.

Switching to tty2, startx gives

(EE) Fatal server error: (EE) no screens found

I tried to reinstall/rebuild my Nvidia drivers using nvidia-all countless times, no difference.

I had linux57-headers installed beforehand.

Updating mirrors and upgrading didn’t help (connection was configured properly via nmtui).

I also tried downgrading to kernel version 5.4, but that didn’t help either.

Any suggestions? Thank you in advance.

Manjaro is bringing its own helper tools to install nvidia drivers. Try mhwd

I suggest you delete any nvidia related packages that you manually installed and start from scratch with mhwd.


Huh, I forgot to try that. It worked. However, I still need Vulkan beta drivers. They didn’t seem to install properly on 5.4 either, so… I think I’m out of ideas. The sole problem was that I haven’t updated my packages. Problem solved.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.