Startup hangs with Nvidia not ready

I recently installed Manjaro and am very excited about using it; it runs much faster than Windows :slight_smile:

However, I have had a problem come up every so often when I startup which causes the boot / loading process to hang. This is the output from the startup debug screen (more or less since it’s OCR’d from a photo I took):

5.4676501 audit: type=1130 audit (1680193772.604:25): pid-1 uid=0 auid-4291967295 ses-4294967295 msg-' unit-sys
5.4684761 audit: type-1130 audit (1680193772.604:26): pid-1 uid-0 auid=4294967295 ses-4294967295 msg-*unit-blu
Started Bluetooth service.
5.4731781 systend-journaldl2721: Successfully sent stream file descriptor to service manager.
Reached target Bluetooth Support.
Starting Hostname Service..
5.4773761 systend-Journaldf2721: Successfully sent strean file descriptar to service manager.
Started Authorization Manager.
5.4797361 systemd-journald[2721]: Successfully sent stream file descriptor to service manager.
Starting Modem Manager ...
Starting Thunderbolt system service...
Started Network Manager.
Reached target Network
5.4907991 systemd-journaldl2721: Successfully sent stream file descriptor to service manager
Starting CUPS Scheduler.
5.493778 system- journald[272]: Successfully sent stream file descriptor to service manager.
Starting Permit User Sessions.
Finished Permit User Sessions.
Started Hostname Service.
5.5289941 NET: Registered PF_QIPCRIR protocol family
5.5625581 systemd-journaldl2721: Successfully sent stream file descriptor to service manager.
Starting Hold until boot process finishes up...
5.5642291 systemd-journald[272]: Successfully sent stream file descriptor to service manager.
Starting Terminate Plymouth Boot Screen...
Started Modem Manager
5.5684541 sustemd-Journalal2721: Successfully sent stream file descriptor to service manager.
Starting Network Manager Script Dispatcher Service..
Started Thunderbolt system service.
5.6893351 systemd-journaldl2721: Successfully sent stream file descriptor to service manager.
5.7242951 input: HDA Intel PCH Headphone Mic as /devices/pc10000:00/0000 :00:1.3/sound/card0/input 19
5.7252491 input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pc 10000:00/0000:00:1г.3/sound/card0/ input20
5.7260891 input: HDA Intel PCH HDMI/DP, pcm=7 as /devices/pc10000:00/0000 :00:1г.3/sound/card0/input21
5.7267711 input: HDA Intel PCH HDMI/DP,pcm-8 as /devices/pc10000:00/0000:00:1f .3/sound/card0/ input22
5.7402721 systemd-journaldl2721: Successfully sent stream file descriptor to service manager
6.0224791 systemd-journald[2721: Successfully sent stream file descriptor to service manager.
8.7405771 nvidia 0000:01:00.0: not ready 1023ms after resume: giving up

I have tried to update my Nvidia drivers with

$ sudo mhwd -a pci nonfree 0300

And it seems they are updated, but the problem has persisted since I first installed.

Running nvidia-smi seems to indicate the GPU is not being used, although I can see it in NVIDIA Settings. My GPU is an Nvidia GeForce GTX 1650 Ti Portable.

| NVIDIA-SMI 525.89.02    Driver Version: 525.89.02    CUDA Version: 12.0     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   46C    P0     4W /  50W |      4MiB /  4096MiB |      0%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A       547      G   /usr/lib/Xorg                       4MiB |

Does anyone know what may be causing this or how I could fix it? I end up needing to hard restart my computer every time it happens which does not seem safe or healthy.

provide full system info:
inxi -zav7
mhwd -l -li

1 Like

Let me think… you think you have only an NVIDIA card, while it is running with the INTEL chipset? On hybrid gpu’s, the iGPU is the default and the nvidia card can be run ondemand. So without using optimus-manager you would need to run a program the nvidia card like that:

# integrated GPU
glxinfo | egrep 'OpenGL renderer'
# dedicated GPU (Nvidia)
prime-run glxinfo | egrep 'OpenGL renderer'

That must be some issue with the NVIDIA card on wake up after suspend/hibernation. I am sure this problem was addressed here on the forum or even on the web. Simply use a search engine.

As a hint: the NVIDIA module has to be loaded early, so include it into the kernel image.

1 Like

Here is the full system info from inxi -zav7:

  Kernel: 6.2.7-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.2-x86_64
    root=UUID=b76c0e69-80c2-4968-a9bf-b9c2e9dcc5fe rw nosplash debug
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 15 9500 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 05XYW7 v: A00 serial: <superuser required> UEFI: Dell
    v: 1.21.0 date: 02/13/2023
  ID-1: BAT0 charge: 54.4 Wh (75.0%) condition: 72.5/84.3 Wh (86.1%)
    volts: 11.6 min: 11.4 model: SMP DELL 70N2F95 type: Li-poly serial: <filter>
    status: discharging
  RAM: total: 15.25 GiB used: 2.28 GiB (14.9%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake
    gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
    model-id: 0xA5 (165) stepping: 2 microcode: 0xF4
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2300 high: 2600 min/max: 800/5000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2600 2: 2600 3: 801
    4: 2600 5: 2600 6: 2600 7: 2600 8: 2600 9: 800 10: 2600 11: 2600 12: 2600
    bogomips: 62431
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs
    ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx ospke pae pat
    pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts
    rdrand rdseed rdtscp rep_good sdbg sep sgx sgx_lc smap smep ss ssbd sse
    sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: eDP-1 empty: DP-1,DP-2,DP-3 bus-ID: 00:02.0 chip-ID: 8086:9bc4
    class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Dell
    driver: nvidia v: 525.89.02 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-03) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f95 class-ID: 0302
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-11:2 chip-ID: 0c45:6d14 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.7 compositor: kwin_x11 driver: X:
    loaded: modesetting dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.00x12.48")
    s-diag: 599mm (23.57")
  Monitor-1: eDP-1 model: Sharp 0x14d1 built: 2020 res: 1920x1200 hz: 60
    dpi: 145 gamma: 1.2 size: 336x210mm (13.23x8.27") diag: 396mm (15.6")
    ratio: 16:10 modes: 1920x1200
  API: OpenGL v: 4.6 Mesa 22.3.5 renderer: Mesa Intel UHD Graphics (CML GT2)
    direct-render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:06c8 class-ID: 0403
  API: ALSA v: k6.2.7-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.65 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active tools: pacat,pactl
  Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks
    driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-14:3 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 953.87 GiB used: 110.14 GiB (11.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2200S NVMe 1024GB
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 22001070 temp: 34.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 953.57 GiB size: 937.53 GiB (98.32%)
    used: 110.09 GiB (11.7%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: b76c0e69-80c2-4968-a9bf-b9c2e9dcc5fe
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 51.1 MiB (17.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: N/A uuid: 1F7A-CB7F
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-11:2 info: Microdia Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0c45:6d14 class-ID: 0e02
  Device-2: 1-14:3 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-2: 2-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-3: 3-0:1 info: Super-speed hub ports: 10 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 38.0 C pch: 35.0 C mobo: 30.0 C
  Fan Speeds (RPM): cpu: 0 fan-2: 0
  Processes: 288 Uptime: 1m wakeups: 2621 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: 1235 pm: pacman pkgs: 1228 libs: 335 tools: pamac pm: flatpak
  pkgs: 7 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.26

And mhwd -l -li

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-prime            2021.11.04               false            PCI

Warning: No installed USB configs!
> 0000:01:00.0 (0302:10de:1f95) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.11.04               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.11.04               false            PCI
          video-nvidia            2021.11.04               false            PCI
    video-nvidia-470xx            2021.11.04               false            PCI
           video-linux            2018.05.04                true            PCI

> 0000:00:02.0 (0300:8086:9bc4) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.11.04               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.11.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

I will do this going forward in other posts; thanks for the help!

Thanks for letting me know about running programs with the Nvidia GPU; I had actually already installed optimus-manager and am planning on setting up GPU use later. I was primarily concerned with the startup/shutdown error, so I provided the nvidia-smi information as I thought it was relevant.

It does seem the issue is with the Nvidia card waking up after hibernation. I am unfortunately not very familiar with these things, so I only had the error message to go off of. I will search with new vocabulary from your input now, thanks.

It does seem to me that a module named ‘nvidia’ is successfully loaded using lsmod | egrep 'nvidia'. Why it sometimes does not load and sometimes does is unclear to me, but I will continue looking :pray:

:information_source: Optimus Manager seems to cause more problems than it solves. It’s always been a hot mess. The only reason why it’s in the repos right now is because of our hardware partnership with Slimbook. I have an Intel + NVIDIA laptop and will never use it.

1 Like

Thanks for the input; I will keep this in mind while working with it.
Is this from personal experience or is it a more widespread issue? What alternatives do you recommend to people trying to decide?

The AMD & Intel controller programs don’t work right and their Debian packages are packaged terribly. I was in contact with them long before Manjaro partnered with them regarding my AUR packages. I granted them Co-Maintainer and they did nothing—well, except for reverting one of my commits improperly and inappropriately. Since then, not a word and they haven’t touched the AUR.

As far as the hardware partnership, @philm & @oberon manage things like that.

1 Like

Sorry, forgot to answer that question in my first reply. One alternative is envycontrol which is in the AUR (Arch User Repository). I had been hesitant about adding it to the repos as the developer mentioned he might not be able to continue with it, however the community has been helping.

There’s even a GNOME Shell Extension for it that I have added to the AUR, but it’s not ready for GNOME 44 yet.

I also forgot to mention that I use my development laptop primarly as a desktop replacement, so it always stays on my desk with three monitors connected to it. I have it setup to only use the NVIDIA card. See NVIDIA Optimus - ArchWiki for more info.

1 Like

you provided 2 times the inxi output, instead of the mhwd -l -li…

and for the early loading:
kate /etc/mkinitcpio.conf
and edit the modules section to look like this:

MODULES=(i915 nvidia nvidia_drm nvidia_uvm nvidia_modeset)

save it and update it:
sudo mkinitcpio -P
reboot, and see if the startup hangs are gone…

and if you want to use optimus:
edit the file:
kate /etc/sddm.conf
and simply put a # before the line starting with DisplayCommand and the one starting with DisplayStopCommand:
(you may not have there these lines, so proceed with installation)
save the file and install optimus:

sudo pacman -S optimus-manager optimus-manager-plasma


1 Like

I think it is a good thing to try/do for Nvidia boot issue.

1 Like

Apologies for giving the wrong output; just fixed it.

I have tried restarting three times after applying your fix, and it seems to have worked! The error is no longer appearing. Thank you so much :slight_smile:

As an aside, is there any way I, as a new person who has little knowledge of Linux, can help the community? It does not seem right for me to only come to the forums for help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.