Starship prompt won't work on manjaro KDE plasma

I have tried to set-up starship on manjaro but I can’t get it right.
I have installed starship-git from add & remove software app.
after adding the needed command to .zshrc eval "$(starship init zsh)" the Konsole doesn’t change to starship, however when I run the command $SHELL I get into starship just fine.
I tried adding $SHELL to .zshrc but to no avail, it didn’t work, I am not sure what I’m doing wrong

1 Like

Sounds like konsole doesn’t use your default shell.
It needs to be configured in the konsole profile you’re using. If I’m not mistaken, you can even use $SHELL instead of an absolute path to the binary there.

3 Likes

:+1: Welcome to Manjaro! :+1:

As you haven’t responded after 21h, I’m guessing you tried to give an exact description of what you’re facing but you’re not understanding the answer.

If you don’t know what we’re talking about, please say so.

If you do know and that helped you, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

I fixed it by disabling POWERLINE in zshrc

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.