Stall when pressing login button

Dear all,

I have been using Manjaro without any major problems for the past year or more. However I’m now facing one that I can’t seem to be able to resolve.

Once I boot and arrive to the login page, I can enter my password but once I press the login button everything freezes except for the mouse cursor which I’m allowed to move.
I tried rebooting several times but nothing changes. I looked up on the various forums for a long time but (maybe due to my incompetence) I’m not able to resolve the issue.
I also tried creating a new user through the tty but I get the same error.
Often was suggested to login from the tty and run the command ‘sudo startx’. The following is what I get:

“X…Org X Server 1.20.8
X Protocol Version 11, Revision 0
Build Operating System: Linux Manjaro Linux
Current Operating System: Linux ls-msi 4.19.126-1-MANJARO #1 SMP Wed Jun 3 22:30:22 UTC 2020 ×86_64
Kernel command line:BOOT_IMAGE=/boot/vmlinuz-4.19-×86_64 root=UUID=0ef230ce…
Failed to connect to bus: No such file or directory dbus-update-activation-environment: error: unable to connect to D-Bus: Using X11 for dbus-daemon autolaunch was disabled at compile time, set your DBUS_SESSION_BUSS_ADDRESS instead. Couldn’t exec startkde: No such file or directory. xinit: connection to X server lost
Waiting for X server to shut down. Server terminated successfully. Closing log file.”

Any help would be really really appreciated.

No. You never use sudo startx with your username … is messing the home permissions. Fix that with:
sudo chown -R $USER:$USER $HOME

If you use the .xinitrc in your home directory then change from:
DEFAULT_SESSION=startkde
to
DEFAULT_SESSION=startplasma-x11

You did not updated the system in long time. Stable branch is already at 4.19.154 kernel version …

sydo pacman-mirrors -f && sudo pacman -Syyu