[Stable Update] 2024-05-29 - Kernels, Plasma 6.0.5, GNOME 46.2, Mesa

After upgrading directly to this update release, I only get the warning for those very old kernels 4.19, 5.4, 5.10

Will see if it can be fixed by reinstalling them simply.

Continuing the discussion from [Stable Update] 2024-05-18 - Linux-Firmware, PHP, Gitlab, Qt6:

The hooks look fine in /etc/mkinitcpio.conf now:

HOOKS=(base udev autodetect microcode modconf kms keyboard keymap consolefont block filesystems fsck)

Comparing to the warning in pacman.log:

[2024-05-29T22:44:45+0200] [ALPM-SCRIPTLET] WARNING: The 'plymouth-encrypt' and 'sd-plymouth' hooks are depreciated. You should replace them with 'encrypt' and 'plymouth' hooks in your 'mkinitcpio.conf'. The 'lxdm-plymouth.service', 'lightdm-plymouth.service' and 'sddm-plymouth.service' systemd service files are no longer recommended. You should enable 'lxdm.service', 'lightdm.service' or 'sddm.service' instead.

And there are no files in /etc/mkinitcpio.conf.d/

Updated within KDE GUI (Wayland). No Issues but Firefox acting weird like unclickable buttons until i min/maximize. But its not crashing anymore like it did on unstable.

No Issues with gaming. 555.42.02 NVIDIA 4080 TI

1 Like

Congratulations for this new stable update, no issues so far.

but, something go wrong during a stable build iso image

error: target not found: spectre-meltdown-checker
[nls@lap ~]$ sudo buildiso -f -p kde -b stable -k linux66 2024.05.30
[sudo] password for nls: 
 --> Profile: [kde]
==> Start building [kde]
==> Cleaning up ...
  -> Deleting chroot [rootfs] (x86_64) ...
  -> Deleting isoroot [iso] ...
 --> Loading Packages: [Packages-Root] ...
==> Prepare [Base installation] (rootfs)
 --> mirror: https://mirror.easyname.at/manjaro/stable/$repo/$arch
==> Creating install root at /var/lib/manjaro-tools/buildiso/kde/x86_64/rootfs
  -> Installing packages to /var/lib/manjaro-tools/buildiso/kde/x86_64/rootfs
:: Synchronizing package databases...
 core      139,8 KiB   518 KiB/s 00:00   [###############################] 100%
 extra     8,3 MiB       17,1 MiB/s 00:00 [###############################] 100%
 multilib  144,9 KiB   495 KiB/s 00:00   [###############################] 100%
error: target not found: spectre-meltdown-checker
==> ERROR: Failed to install packages to new root
==> ERROR: Failed to install all packages
[nls@lap ~]$ 

spectre-meltdown-checker has gone don’t think its in root packages, is it in your desktop packages if it is remove it

1 Like

Did you try booting from USB/disk into a rescue system and mounting the volume manually inside of that? Did that work? If yes, do you have the encrypt hook in /etc/mkinitcpio.conf?

I don’t use Wayland (maybe i should try it again, not sure) but no, i can not see the ink levels in the printer setting gui. No one has suggested a shell command to access it either, so i think i will have to buy a new printer. So now i start searching for that. :frowning: Anyhow, screen shots here

I’m still working on the VPN, I’m starting to suspect its just a coincidence that it stopped working at the same time as the update. I’m waiting for a response from my vpn provider.

Yea i am watching it being worked on. As i say i wouldn’t say anything if kde had a working calendar of its own.

Sure i could, if i wanted it sometime this decade. I wouldn’t know where to even start.

I never reed the announcements before, i did not know how it was supposed to work. I suspected it was more likely a mistake on my part, so i asked.

After the update, the keyring database got corrupted, so that sudo mhwd-kernel -i linux69 wasn’t possible (The full error has scrolled off the recall in konsole but is was a corrupted (invalid or corrupted package (PGP signature) error.

After rummaging through the forums I found the following sequence that works:

sudo rm -rf /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate
sudo pacman -S manjaro-keyring archlinux-keyring

Then I was able to install the 6.9 kernel.

I’m not sure why the gpg database got messed, but am posting this in case it happens to anyone else.

3 Likes

Update was smooth, cheers again.

1 Like

There was not the encrypt hook in /etc/mkinitcpio.conf.

Thank you very much.

How can I run the equivalent of local:

mkinitcpio -P

in the GNOME Live .iso, so as to fix the issue?

Thank you.

1 Like

the xz version 5.6.2 has been released that fix the malicious backdoor, while it’s still
xz 5.6.1-3. in stable. it’s worth to update it in the packages to fix the story finally.

2 Likes

Thanks guys, everything went well!

1 Like

Only one minor obvious issue; radicale now spams the journal with verbose messages. As there’s no obvious way to lower its verbosity level, I fixed this by creating a radicale.service override file redirecting its output to a log file.
Edit: this can be changed by editing the configuration file and adding the following line to the [logging] section:
level = error

Just mentioning in case anyone else happens to be using it and wants a fix.

Tooltips do not appear when I mouse over buttons when I use the Qt6 version of Double Commander. When I use the Qt5-version, tooltips work. Maybe upgrading qt6-base has something to do with it. I have posted a report on the Double Commander forum. Tooltips not shown on Qt6, are OK on Qt5

Tooltips work fine in Dolphin and LibreOffice, so no worries.

I never was in that situation but I think the right way would be to chroot into your system and then run mkinitcpio. You could also try something along the lines of mkinitcpio --config /path/to/mkinitcpio.conf --generate initramfs-x.x-x86_64.img and then manually replace the image in /boot but I am not sure about that. Maybe somebody else can chime in? I think chroot is the “correct” way.

Hi everyone, sorry I’m new to manjaro and I hope you will have a little patience. I have a question regarding the latest update. After the update I started:
“pacnew-checker” and it reported the presence of mkinitcpio.conf.pacnew. With Meld I saw the differences between the two files. I never made any changes in the original mkinitcpio.conf file, can I replace the original file with the new one? I believe and correct me if I’m wrong that the spirit of “pacnew” is to prevent a configuration file, perhaps modified by the administrator, from being overwritten without first being checked and possibly reporting the changes to the new one?
Thank you for your availability

1 Like

yes

Exactly. A simple concept not understood by many.

3 Likes

i added the microcode last update,idk about you other hooks.

1 Like

Using KDE kernel 6.9 Update went smooth with everything except
vmware-horizon-client

This broke on 24-5-13 upgrade and still doenst work with this upgrade
I cant be the only one that this software stopped working

There seems to be a big problem with memory leaks with Plasma in this update.

Plasmashell starts up using about 250M, with kglobalacceld at about 8K.

After a period of editing photos in the Gimp, I noticed my RAM use had grown to nearly 100%. Closing Gimp reduced it a bit, but not much. Digging in, I could see that plasmashell was now using an insane 5G and kglobalacceld was using over 3G.

Trying
plasmashell --replace
at first left me without plasmashell even running, but issuing that command again brought it back, but already using about 3G. Only logging out and back in again released the excess memory.

No idea where to go from here at the moment…

On Plasma KDE bright widget works on first display (and don`t change bright on second display)
Bug occur after last update

1 Like